Suzuki Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
I recently purchased a 2002 xl-7 it has the 2.5 and 82K miles...

Suzuki told me that could preventative work would be to replace timing chain tensioners. So I did.

When I picked up XL7 I drove about 10 miles on interstate to red light when I pulled away from red light a large significant amount of whitish brown smoke poured out my tailpipe and the engine spark knocked significantly. Smoking stopped after 100ft or so of driving.

I returned to shop where they kept machine for two days. They gave it back to me and it was fine they said they found a "broken hose".

The smoking stopped and vehicle ran well.

On the sixth day my wife backed it into the garage and it smelled of burning coolant.

After several days of checking coolant levels and watching the xl7 it only got worse and the coolant was starting to pool on the garage floor near the back of the engine.

I returned to garage again. Garage had xl7 for 5 days. They told me they replaced all seals on the upper rear part of engine. They said it's coming from the back of the motor but they don't know where.

I picked up XL7 today and when my wife got home she told me that it is blowing smoke out tail pipe again and I can still smell "lots" of burning coolant when it is parked in our garage.

Any and all help would be greatly appreciated... I have spent alot of money and time at Enterprise rent a car and this machine simply does not wish to be fixed...
 

·
Super Moderator
Joined
·
4,421 Posts
first of all. Is it a US XL7? If so its a 2.7 not a 2.5 motor.. Second, the car is a car. Any car can be repaired.. The mechanics who can't repair a vehicle is the problem. You need to find a new dealer or a new mechanic. Its obviously related to the work they recently did.. so its THEIR problem for not repairing it correctly .. not yours.. Make sure they know this..

did th eengine overheat when this first happened after the tensioner replacement? If so you may have done head gasket damage or warped a head.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #3
never overheated.... 2.7 okay... people working on machine are trusted and have proven to be qualified in the past. I replaced tensioners because they made a little noise. So much for tring to take care of something. I should learn to leave well enough alone... Coolant leak is near rear of engine they just can't seem to locate it. Also smokes white when you first start it up too.
 

·
Super Moderator
Joined
·
4,421 Posts
Im thinking head gasket.. Sure sounds like it overheated.. if a hose did indeed break and you lost the coolant you will overheat very quickly
 
1 - 4 of 4 Posts
Top