Suzuki Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
lights were getting dim at night, suspected alternator. charged battery < alt light came on intrermittently with airbag light sometimes. now turns over very slow
 

·
Registered
Joined
·
4,458 Posts
flat battery and a suspect alternator by the sounds of things
 

·
Registered
Joined
·
447 Posts
What year is your Esteem?

I would suggest you remove your battery cables, clean battery posts, battery cable terminal clamps. Charge up battery and see if it improves. Verify that the cable terminals are tight on the battery posts.
My battery cable terminal clamps had stretched and did not make a good contact with the battery posts. It made for some compound to form between the battery cable terminal clamps and the battery posts. This made for poor conductivity. I tried to make a better fit by screwing in a screw to tighten the clamping of of the clamp but that did not work, I was still getting dead batteries. I changed the battery terminal clamps and this solved the issue once and for all. An easy fix with these terminal clamps.
https://www.ebay.com/itm/Car-Battery-Terminals-Clamp-Screw-Connection-and-Cable-Fitting/202294244141?hash=item2f19ad332d:g:mlwAAOSwPBFa2pHQ&_sacat=0&_nkw=battery+cable+terminal+clamp&_from=R40&rt=nc&_trksid=m570.l1313&LH_TitleDesc=0

I feel the terminal clamps are prone to stretching, and failure, my humble opinion.

Mine is a 2000 GLX wagon 1.8L.
 

·
Registered
Joined
·
66 Posts
Alternators are a pain in the ass to change on these things lol. I would check to see if your power steering reservoir isnt dripping onto the alt. (where the return hose attaches on bottom)
 
1 - 4 of 4 Posts
Top