Suzuki Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a question. I recently purchased a 2006 Forenza. I have used the windshield wipers all of three times. I don't know if it is the motor, or what, but they will not come on at all. The weather here has been generally crappy (sleet, snow) and, yes, I put de-icer on thinking that they were just frozen. The ice has melted and they still will not work. I really do not want to have to mess with taking it in. Any suggestions?
 

·
Registered
Joined
·
2,069 Posts
Take your car in to the dealership and explain them the problem. Because it can be anything from a bad fuse, to faluty wireing to a dead motor, or it might be due to the weather even.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Great

Thanks!!!! Yeah, I tried replacing the fuse, it just blew the new one. The motor is blown. I called the dealership and was informed that along with myself, there are 13 other Forenza owners with the same problem. There is a four day wait on the parts and I have yet to find out if it is covered under warranty and/or if they are going to provide me with a replacement vehicle until it is taken care of. If not, the cost is $112. I have had several vehicles and have driven in the weather conditions we are experiencing right now without any issues like this. I can only assume this is a common problem with the Forenzas so, watch out for it.
 

·
Registered
Joined
·
3,209 Posts
Yeah, must of gotten a bad batch shipped to your dealer. The wipers motor is a new one to us. It should be a free replace for you. Don't lety them say otherwise! If they do, speak to a manager, and call up Suzukis hotline.

Watch out for the 06, it had some parts issues due to GM supplyers getting flaky. Let us know if theres a hard start or no start issue. Thoes crop up early in the vehicals life, and are common problems. Ones a switch on a brand new car needing to be worn in, the other is software
 
1 - 7 of 7 Posts
Top