Suzuki Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
366 Posts
Discussion Starter #1
Fuelpump relay tested fine. Still a problem. Not getting power(juice) to the switch half of the fuelpump relay. Thus,no power back to the left rear taillight area,which then goes to the fuelpump.

Both the fuel pump relay and the ECU get power from the "MAIN" relay. One source (of two sources) is from the fuse BOX, obviously only when the key is ON, and not when the key is in the Accy position. 2 pins on the ECU also come from both the fuse box, and the Main relay. I know where the fuse box is. any Idea which fuse supplies that power to the ecu and fuelpump relay? Also,where is the main relay? Is that the one next to the fuelpump relay?

IF I disconnect the hosefrom the pipe that comes from the fuel filter should I see fuel(gas) spraying out? how long should that happen assuming the fuel lines are all empty?

Jim
 

·
Registered
Joined
·
4,310 Posts

·
Registered
Joined
·
366 Posts
Discussion Starter #3
Pulled the "Main Relay",put the fuelpump relay back in it's place. Will test this one tomorrow. Both have identical part numbers so exactly the same; that's pretty cool. Might get this puppy running again yet.

Jim
 

·
Super Moderator
Joined
·
23,915 Posts
The switch half of the fuel pump relay, coming into the relay, is the blue/black wire coming from the F1 fuse, and connects out to the pink/black that runs to the pump. The black/white wire that comes to the fuel pump relay comes from the ig/coil fuse, and connects out to the pink that runs to the ECU as a switched ground.
 
1 - 4 of 4 Posts
Top