Suzuki Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
As suggested, I drained the fuel tank, blew out the supply line and put a new fuel filter on. The Zuk starts and runs for about 30 seconds and dies out. It will restart again and keep dieing out as before. I am about to pull the carb and hopefully clean it out. It is a 1988, and I am told by my parts folks that there is no rebuild kit made. Does anyone have a line on a rebuild kit? The wife says there is something else wrong with it, and after all, she is the boss. The Zuk ran great prior to getting the water in the fuel, so I think it is the root cause. Any suggestions would be a value. Thanks!
 

·
Registered
Joined
·
1,230 Posts
you can find rebuild kits on ebay. There are some that are just gasket sets, but If you're going to tear into it and clean it out, you should probably get a complete kit that has a new idle jet solenoid etc.

Have you tried runing the fuel supply and return line straight to a jerry can and seeing if it runs off that? I wouldn't think water in the fuel would foul the carburetor, but if something in the tank is floating over the pickup or if theres a restriction in the return line it could also be causing the problem. I would completely eliminate the fuel tank and lines from the equation before I ruled them out.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Baratacus, Yes I had the fuel line in a gas can and it was no different, although I can keep it running if I squirt gas into the carb, I kept it running like that for a half hr. hopeing it might resolve my problem. No good. I started to take the carb off and thought I would check in. I check e-bay for a rebuild kit, Thanks!
 

·
Registered
Joined
·
1,230 Posts
thanks, it seems like we talked about it in a different topic already but I wasn't sure. Memory starts to go when you get old and crumbly. With the fuel bypass already done and it running with fuel direct into the carb it sounds like the carb alright. Refresh my mind about the fuel pump... alredy ruled that out too didn't we?
 

·
Registered
Joined
·
306 Posts
As suggested, I drained the fuel tank, blew out the supply line and put a new fuel filter on. The Zuk starts and runs for about 30 seconds and dies out. It will restart again and keep dieing out as before. I am about to pull the carb and hopefully clean it out. It is a 1988, and I am told by my parts folks that there is no rebuild kit made. Does anyone have a line on a rebuild kit? The wife says there is something else wrong with it, and after all, she is the boss. The Zuk ran great prior to getting the water in the fuel, so I think it is the root cause. Any suggestions would be a value. Thanks!
If it runs at all you should be looking else-ware as far as water goes, especially after you drain the tank and all your lines still getting the same result.

Instead of a full rebuild which could be made from crummy parts here is a cheap and relatively easy solution.

Pull the carb - go buy a can of brake Cleen or carb cleaner and don some goggles.
Spray every jet you can find while lookin IN the carb so to push the funk an gunk OUT of the jets, don't be afraid to use the whole can its only about 4$ as apposed to up to 100$ for a rebuild. See if this solves your issue, if not then you wasted 4$ if it DOES then you just saved 96$ +\-...
 

·
Registered
Joined
·
1,230 Posts
if it's just a random chunk of something that came through it might work. If there is a bunch of build up in the float bowl and its starting to come off and gunk up the jets, it may be an ongoing issue. BTW a rebuilt carb is 300 bucks! I wish I had a back up vehicle to rebuild it myself instead of having to buy one that's been done. 100 bucks for a kit is looking good to me right now.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8
I cleaned out and rebuilt the carb, found a lot of debris in the jets. Anyhow, the zuk now starts, high idle with it being cold out, the motor warms up,
the idle comes down and I let it run for 20 min. Wow, I fixed it, so I take it around the block and then around a couple of blocks, running through the gears, comming down the alley all of a sudden the thing starts sputtering like it is starved for fuel and it dies. It starts right it up and and when you give it gas and let the clutch out, the motor starts sputtering again.
So I get it home, rolling down hill as planned, and park it for for the night.
Next night I go out and the same thing happens.
I gotta get this thing going, wife is starting to get out of hand with the teasing about my little four wheel zuk.
Thanks in advance for any help once again!!!
 
1 - 8 of 8 Posts
Top