Suzuki Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi there i hope some one can give me a answer . my vitara has been fitted with a hif44 carb with a BFM needle it will tick over very nicely but when its revved up quickly it has a flat spot about 1.5 to 2.5 RPM after that its ok the ignition side is still being run by the ECU [it was a single port injection system] a new low pressure pump has been fitted. i hope someone has a answer on this problem Thanks Neil
 

·
Registered
Joined
·
4,357 Posts
Hi there i hope some one can give me a answer . my vitara has been fitted with a hif44 carb with a BFM needle it will tick over very nicely but when its revved up quickly it has a flat spot about 1.5 to 2.5 RPM after that its ok the ignition side is still being run by the ECU [it was a single port injection system] a new low pressure pump has been fitted. i hope someone has a answer on this problem Thanks Neil
Are you an Aussie? Do a search here and contact Rhinoman, I believe he may have some knowledge of carbed UK (and JDM)Suzukis. Good luck.
 

·
Registered
Joined
·
5,299 Posts
The SU is rather fickle, I would suggest that you have a look on the suzukiclubuk site for advise regarding dashpot oil and carb settings. Do you have a modified manifold or an adapter? the adapters are notorious for carb icing problems. Do you have a Check Engine Light showing? it could well be in fail-safe mode which would mess up the timing, even if its not then it soon will be because you won't have sufficient control over the mixture to prevent the lambda sensor from being ruined. You would be better off to use the timing setup from a carb model although you may have to modify the SU to get the correct timing advance, the stock SU vacuum takeoff will give full advance at idle and then retard the ignition.

Suzuki Club UK - Home
 
1 - 4 of 4 Posts
Top