Suzuki Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter · #1 ·
Hi,

Ever since i removed the wiring from the tape player from my 91 vitara,
the auto transmission gear selector light does not illuminate when i turn on the headlights. Im guessing the light was somehow wired through the tape\cd player wiring... I checked all fuses, bulb & light connector.

Any advice would be much appreciated.
 

·
Super Moderator
Joined
·
25,551 Posts
I assume you're talking about the shifter lamp on the console. That is serviced by a red/yellow wire that also runs the backlighting of the radio as well. Just curious - does the light in your ashtray work??
There is a splice, just behind the radio, where this red/yellow wire splices off to go to the shifter lamp. You probably need to check there to make sure the connection is ok.
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #3 · (Edited)
Thanks for the advice Bex.
The ash tray lamp which is connected to a 2 pin plug does not work (connections seem good) & also i noticed the interior light is not working which was working before i removed the radio (not sure if that is related).

One thing i noticed is when i connect one of the pins from the gear shifter lamp connector, to the currently unused female terminal with 2 white wires with brown bands going to it, with an ohm meter, i get 0 ohms when i switch the headlights on (not sure if that is related at all). But the Gear shifter lamp should only work when the headlights are switched on.
 

·
Registered
Joined
·
48 Posts
Discussion Starter · #4 ·
All fixed !!!

i Joined the two white wires with brown bands (which was wired through the headlight switch) to the white wire & all dash lights work.
 

·
Super Moderator
Joined
·
25,551 Posts
Well done! Funnily enough, my FSM doesn't show any white/brown wire regarding radio, shifter lights, etc. - in any event, it had to be a wiring issue, so glad you found it.
 
1 - 5 of 5 Posts
Top