Suzuki Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello, I had a problem with my plug(especially the 4th plug) getting wet with fuel and consequently not burning the fuel.All the other plugs look good as in burning the fuel. I was advised to replace the valve seals, I replaced the valve seals but didnt replace the gasket, but the problem still occurs. Do i have to replace the valve seals and the gasket?
 

·
Super Moderator
Joined
·
15,399 Posts
I'm not sure if we have a translation problem here, but, valve seals are in no way related to fuel being on the plugs - do you by any chance mean oil? Fuel is petrol or gasoline and goes in the tank at the back of the car, oil is the lubricant that goes into the engine. The valve seals prevent the lubricating oil from going down the valve guides into the combustion chamber.

You will also need to tell us which gasket you're asking about, and it would be a good idea to give us the details of the vehicle.
 

·
Registered
Joined
·
326 Posts
what model, year, engine type? 8 valve or 16 valve?
and who exactly advised you to change valve seals to solve the fuel wetting problem? I want to meet this genius...
i am not sure which gasket you DIDNT replace? valve cover? head gasket? jsut try to be a little more specific.
if you hold the plug agianst the engine, can you see it sparking when you crank the motor wiht starter? thats the first thing id check.
 

·
Registered
1991 Hardtop 3-door Tracker 1.6L 4WD 5-Speed No A/C
Joined
·
472 Posts
Another case of "fix first, diagnose later".
 
1 - 4 of 4 Posts
Top