Suzuki Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi there,

Chasing some help on my 1987 Suzuki Sierra, Wont Idle Smooth, When its cold Sits at 1000RPM Is Great Soon as it gets up to Temp Irratic and surges Between 1000RPM and 1500RPM drives fine has plenty of power soon as you put the Clutch in while driving stalls replaced all vaccum hoses checked the choke working fine swapped over EGR valve still nothing, Tested Compression 150 Over all Four Cylinders Tryed adjusting the timing Advanced 5DEG and 20 Deg before Still no good, Replaced fuel filter drained tank Pulled the plugs out All good besides Last plug closest to the Firewall Was black the rest were white. Does this Mean Valve clearenece issue???
 

·
Registered
Joined
·
16 Posts
Hey im having almost the same issue with my 86 samurai: Sometiemes runs smooth and idles normally whithin the 900rpm range and after a few blocks it starts to stall (revs go down extremely fast) if not kept with the foot on the gas. Please someone with a fix help! i´ve been looking everywhere without any luck!!!
 

·
Registered
Joined
·
48 Posts
Aleberro sounds like the problem I had try adjusting the ideal. You can increase it which should raise the RPM's and keep you from stalling. I was finding regularly it was okay but when my A/C was on it died took my 2 minutes to adjust.
 

·
Registered
Joined
·
16 Posts
snakie thanks for the reply but i've already tried to balance the idle in that way, it works until you get on moving and then it stalls again. There must but some problem with the carb sucking air or something. The strange thing is that in the rare cases that it idles in the first time, the revs are extremely unsettled (like if you input a little bit of gas) and when i get on moving and accelerate a bit with it everything goes back to fast dropping revs and stall issues. Its a pain in the a** having to keep the revs up with the throttle in heavy traffic or when breaking. I should probably take it to a specialized garage...
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
ALEBERO:
I would do What Snakie said and I did replace all vaccum hoses 4mm and pulled off carby off and cleaned out the bottom Jets, Put a New fuel Filter, Drained the Tank, Put a small Filter from the outlet of the Fuel pump to intake of the carby just to be sure for $20.


One Question Is your car Surging or missing??
 

·
Registered
Joined
·
111 Posts
Hey guys have you pulled the top off your carbs and cleaned all the jets and passages inside? That's what I just had to do to mine. It runs much better now (wouldn't idle at all and had poor acceleration) the inside wasn't real dirty but the accelerator pump nozzle was completely stopped up.

Mike
 

·
Registered
Joined
·
16 Posts
Hey Mikeww i will look into that as well, i have another question: i have the stock carb on my sami, when passing 3500-4000rpm the engine stops pulling hard and drops a bit (like if it was drowning and then starts pulling again. It seems to be the second carb "chamber" opening, but im not sure, do you know how to tune that up?
 

·
Registered
Joined
·
111 Posts
There is a tube upgrade that is in the FSM but I haven't got that far with mine yet, search this forum I'm sure you can find reference to it from some of the senior members.
 
1 - 12 of 12 Posts
Top