Suzuki Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 2004 suzuki vitara 4WD V6

My dad and i added a can of freon to the vehicle and soon after the fuse for the blinkers blew. the flasher is fine, 4-ways work. might have caused a short while working on it?

i switched it (10A mini) and got a few days before it blew again. now when i switch the fuse and turn it on the engine makes a sound almost like the ignition is firing again for a few seconds and then the fuse pops and the noise stops. could there be something else going through that fuse thats seized and causing the fuse to blow?

i just dont want to spend time trying to find a short if someone here has had a similar experience and found it wasn't a wiring issue.

i hope i've provided enough information, any help would be appreciated.
 

·
Registered
Joined
·
6 Posts
Hi Ahlinn, I've got a similar situation: my turn/back fuse blows every day... not sure what's causing this annoying issue.
Did you find out what the problem was with yours?
Thanks.
 

·
Super Moderator
Joined
·
14,229 Posts
Hi Ahlinn, I've got a similar situation: my turn/back fuse blows every day... not sure what's causing this annoying issue.
Did you find out what the problem was with yours?
Thanks.
Exactly WHAT is your symptom? Does it blow every day or every time you shift into reverse? Details matter.
 

·
Registered
Joined
·
8,798 Posts
Maybe a loose wire connection somewhere.
He's blowing fuses, loose wires result in lack of current flow usually, not excess current flow.
 

·
Registered
Joined
·
93 Posts
Try removing just the front or rear turn signal bulb or just remove both bulbs and see if the fuse still blows. Make sure there is no water or bare/loose wires in either front or rear RH sockets.
 
1 - 6 of 6 Posts
Top