Suzuki Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I have a 2004 Suzuki Verona with ~40,000 miles. It has been a very good car and I think we got a real deal with it. Just recently I have started having trouble with the transmition. When coming to a stop the engine revs up and when it shifts down it jerks forward. I have an apointment to have it looked at on Monday Nov 21, 2005, but I was wondering if anyone else has had anthing like this happen with this car?
 

·
Registered
Joined
·
2 Posts
I did have this issue around 15K-20K. I took it into the dealer but they don't tell me much or admit things are wrong. Although I am not having issues anymore after that visit. I would be interested to hear what you find out or what they do.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Good to know, I had to delay my appointment because I became a father. I am taking it in on Friday. I will let you know how it goes? How long ago did this happen to you?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
The dealer blamed it on programming. They reprogrammed my system with new firmware and it seems to have solved it at least on the trip home (45 minutes to the closest reputable dealer). Didn't give me any more information than that. It was covered under the environmental waranty thought.
 

·
Registered
Joined
·
5 Posts
I also went for the computer upgrades/reprogramming? after my 04 Verona would occasionally slip out of gear. I didn't get much of an answer from the dealership either regarding these problems. Everthing seems to be back to normal now though....except i'm hearing a slight winding sound when going through first and second?? I still would like the lower gears to be more responsive....Do you sometimes notice(like when hitting the gas to pass etc..) there can be quite a hesitation before the transmission will downshift?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
Again tonight my check engine light came on and now it acts like it won't change out of third gear, even if I manually shift it to low, or put it in hold mode. When I got home from church I could smell the heat coming off the transmition. This has me extraordinarily worried, I have only had the car since Oct 2003 and am already having major problems with it. I still owe a ton of the car.

Just after getting the code uploaded I had a few times the gears seemed to slip also. It stopped and I didn't worry too much about it, but now I wonder if it was leading to this.
 

·
Registered
Joined
·
5 Posts
I haven't had any problems with my check engine light so far. That does make me worry though with the transmission problems you're now having ... with my Verona a little under 30,000 miles and already having had some of the same issues. Does the trans shift fairly quietly? I've noticed a winding sound that comes and goes recently in 1st and second that doesn't sound too good. Of course when I took it up to the dealership...never made a sound for them!!!??...I'm going in for my 30000 maintenance, so maybe i can get the trans looked at again!? I hope I'm not looking at bigger trouble down the line...
 

·
Registered
Joined
·
18 Posts
My 'check engine' light came on about 6 months after I bought my Verona. This light will come on if your gas cap isn't on all the way or you bought some bad gas along the way according to the manual. It is designed to pick up on the air that is in the gas lines. The manual says that switching to a different brand or cleaner gas after a couple of tankfuls it should go away. Mine didn't so I took it in and there was a small hose that was disconnected. After that never had a problem with those pesky lights.

[email protected]
 

·
Registered
Joined
·
8 Posts
Discussion Starter #9
That happened before the reprogramming. It has not turned back up after the new code load. I have noticed that it shifts harder (more jerk) since the code load, but it is also more reliable about how it shifts. I took it back in to the dealer again to have some work done (Heater and Battery replaced), but the forgot to get the codes off the system before they replaced the battery. I will let you know if I see it again.
 

·
Registered
Joined
·
1 Posts
My 2006 Forenza wagon has a problem with down shifting when going down a steep slope. When coasting, and it has to be steep for that, it will down shift at 45 mph and go back up at 50 mph. I even have to keep my foot on the gas while going down hill. It has been to service 4 times now. Reprogramed the computer, still does it. I do not get the same mileage as my girlfriend, who by the way has the same exact car, we bought them within 1 day of each other. I am waiting on a call from Suzuki to see what they can do. I am not looking forward to driving this car in the winter with the tranny acting up like this.:(
 
1 - 10 of 10 Posts
Top