Suzuki Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 2004 Suzuki Jimny and it appears to me that the auto transmission is suck in a high gear. When I turn on the switch, I hear a clicking sound coming from around the glovebox and also coming from the transmission. It moves very slowly when I step on the gas to take off and when it reaches a speed, it sound as if there is no gears changing, and the clicking sound also stops when the vehicle is moving.

Model Number: FJB43V Engine: M13A

I ran a diagnostic test and these were the results:
P0753. SHIFT SOL A ELECT (LOW V)
P0763. SHIFT SOL C ELECTRICAL
P0768. SHIFT SOL D ELECTRICAL
P0743. TCC SYS ELECT CRT (LOW V)
 

·
Registered
Joined
·
173 Posts
put the rear of the vehicle on jack stands and see if it shifts...... starting off in high gear will burn out your transmission.
Joe
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
It doesn't shift when on stands. When taking off on a level surface, you have to press on the gas and it takes a while to accelerate. The vehicle reverses fine but when in any of the forward gears it take a while to accelerate. I am certain that it is stuck in a high gear. It's like riding the clutch on a manual vehicle except no gears are changing. The transmission also makes a drone sound when it takes up speed.

I need to know if the ecu can cause this is or the transmission is ruined. As you can see from the diag test, there's definitely something wrong.
 

·
Registered
Joined
·
173 Posts
My knowledge on auto transmissions is very minimal..... I don't want to misguide you and hopefully someone else can chime in.
Joe
 
1 - 4 of 4 Posts
Top