Suzuki Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
I just got a 81 LJ80 and after putting it on the jackstands and giving it a once over, I found the bushings have separated for the transfer case and its just flopping around. It was a piece of rubber sandwiched between two steel plates, the rubber and the metal no longer hold to each other. My parts guy cant find any parts. Is there anywhere to find replacement parts that you guys can reccommend ?
 

·
Registered
Joined
·
212 Posts
Sounds to me like u have a failed t/c mount.
If u cannot find one for LJ80 u have at least two choices.
U can adapt a 413 or Sami one...some modifications.
U can jury rig the broken one with a bolt or use a bolt instead of the mount.
Now to be creative. (3rd choice) The little Nissan/Datsun (here called Versa) uses a similar rubber mount. They do not have the same size bolt so some adjustments need to be made.
So if the mount is the problem this may help.
Good luck with the LJ...my favourite Suzuki.
Had several.
S l o w.... s l o w fun eh ?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Thanks for the suggestions ! We have rigged up the mounts by running several bolts through one side and into the rubber of the mount.

But once you find something wrong you find more so it may be a whe before it's all put back together and back on the trails.

I wish I had taken pictures. Its not back on the suzuki yet but i'll let you know how it works once it's all back together :)
 
1 - 3 of 3 Posts
Top