Suzuki Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
I purchased a 2009 XL-7 with a bad motor for $600. I purchased a motor from a 2007 XL-7 or Grand Vitara (can't remember which one) off ebay but the cams were worn on one side so they refunded my money & told me I can keep the motor. I purchased a rebuilt head & cam for $450 & all the stuff to do the timing chain since they are a known issue with these motors (I ordered the stuff for the 2007 motor not the 2009). When we went to install the new timing chain it did not fit. The mechanic that was doing it said the motor takes a roller chain but the kit I was sent was not.
So my question in all this is where is the mess up? Posting pics to see if they help


Sent from my SM-N960U using Tapatalk
 

·
Super Moderator
Joined
·
18,422 Posts
Like you, we do not know exactly which of the V-6 engine designs you are working with in order to provide part obtaining guidance.

One note of concern though...where do you think all of the displaced metal (now debris) from the old camshafts resides at? Yeah...thruout the engine to include the bearings.

I hope that you are doing a FULL engine disassembly and inspection. :oops:
 

·
Registered
Joined
·
18 Posts
Discussion Starter #3
We took everything else apart & it looks good. The cams on the 1 side were the only thing worn. Is there a was I can look up a number on the block or something to find out?

Sent from my SM-N960U using Tapatalk
 
1 - 3 of 3 Posts
Top