Suzuki Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a relatively new 2003 Suzuki Aerio’s model that has just over few thousand miles on it.
The car ran great up until about a thousand mile, then it started pinging or knocking upon hard acceleration on the flats or going up a grade of any sort. There is no engine service light on and the dealer has scanned it and it shows no service codes and they said that there's not much they can do. Nice, huh?……The car is definitely pinging/knocking very hardly…..
Any help from anyone would be greatly appreciated
 

·
Registered
Joined
·
38 Posts
Have you changed the type or brand of gas you are using? Try a tankfull of name brand premium and see if that quiets it down. The car is set to run regular grade gas but if you have been using the cheepest no name brands out there that may be it. I allways use the same brand of gas from the same station for consistency and my 2003 SX AWD runs perfectlyat 15,000 km.
 

·
Registered
Joined
·
56 Posts
To add to what Biggles says, get your gas from a station thats less then a year or two old. Tanks age. I always try to get my fuel from the newest station available in my area.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
well.....biggle......i think u r right........my cousin also faced the same problem......and he told me that it's always been associated with low grade fuel......now today onwards....i will use the good brand of gas from the same station as u r suggesting.....thanx....









Originally posted by Biggles@Aug 3 2004, 09:14 AM
Have you changed the type or brand of gas you are using? Try a tankfull of name brand premium and see if that quiets it down. The car is set to run regular grade gas but if you have been using the cheepest no name brands out there that may be it. I allways use the same brand of gas from the same station for consistency and my 2003 SX AWD runs perfectlyat 15,000 km.
 

·
Registered
Joined
·
4 Posts
Margo,where do you live? Some guys on another forum are trying some cooler spark plugs. Some feel the stock plug has a too high of a heat range for the US and even parts of Canada. My car will ping at times,mostly in very hot temps[I live in Alberta,Canada.] I will ran mid grade fuel on holidays and never have any pinging. BTW the guys using the cooler range plugs say it really helps. The plugs are listed as recommended replacements for the 2.0l aerio.
 

·
Registered
Joined
·
22 Posts
Originally posted by jamie1@Aug 7 2004, 06:29 PM
Margo,where do you live? Some guys on another forum are trying some cooler spark plugs. Some feel the stock plug has a too high of a heat range for the US and even parts of Canada. My car will ping at times,mostly in very hot temps[I live in Alberta,Canada.] I will ran mid grade fuel on holidays and never have any pinging. BTW the guys using the cooler range plugs say it really helps. The plugs are listed as recommended replacements for the 2.0l aerio.
I did the plug swap and the pings are gone...
 
1 - 7 of 7 Posts
Top