Suzuki Forums banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi-

I have a 2002 suzuki vitara. About a year ago it would turn on the dash lights (check engine, o/d lights, etc, as if I had the engine off but electronics still going with key in) and the RPM to drop down. It felt like the engine would give out, but then correct itself about 5sec later and work completely fine, so long as I was going a decent speed. Otherwise if this happened while I was stopped it would just stall. Once it stalled I could just restart the vehicle and precede as if nothing happened.

This would happen completely randomly as far as I could tell. Sometimes it would happen 2-3 times a day, sometimes once a week. And I could see no correlations between when it happened and anything else like weather or electronic/AC usage or engine load, etc.

So I took it in to see if error codes were associated with it but the dealer said there was nothing there and it could be to a bad battery. So I switched the battery out and I didn't have the problem for about 8 months. However it started doing it again, and was wondering if anyone has similar issues?

I tested the battery today and is reading normal voltages (about 12V) and the alternator seems to be working fine as the voltage jumps to about 14V when the engine is on. So I'm quite confused now and could use any help, thanks!
This is what I am experience now,what can be the solution?
 

·
Super Moderator
Joined
·
19,138 Posts
You need to be more specific to start with. Like year, model, engine, codes on a scan?

 
1 - 2 of 2 Posts
Top