Suzuki Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Heya All!
I've had a 08 SX4 since 08. Recently I let my son borrow it and it spun a rod bearing. Stupid expensive to rebuild it and pretty expensive to find a 60K used engine!
It's a touring hatch 4X4 with everything but leather.
I just bought a 09 SX4 but it does not have cruise control, the nicer stereo, climate control or fog lamps. It's a base hatch 4X4.
Does the factory install a general wiring harness or is it specific to the model?
I want to know if everything would bolt across and hook right in or if I would have to change out wiring harnesses to bolt in the nicer options???
Thanx in advance for passing on any info!!!
Dave
 

·
Registered
Joined
·
839 Posts
I would not even dare to think swappîng the wiring.....
HOwever, wife's SX4 is middle model (called JX in Canada) ..does not have fogs , and no auxiliary 12V outlet in the back...but I know (from others on the forum and youtube) that the wiring for those is there. SO...at least, some wiring is common...I do not know for the rest....
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
so far...
yes, the wires for the fog lamps are there, I don't know yet if the wiring is there for the button/switch.
Under drivers seat subwoofer,, wiring is NOT there for it.
Still don't know about switching the steering wheels out for cruise control and radio control.
Cruise control is the main one that I want to get onto this car.
 
1 - 3 of 3 Posts
Top