Suzuki Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello, I have a suzuki samurai 1.3 with a problem. It starts on the button and runs. Its 1991. The problem im having is that when its idling it is normal but when i turn on the fans or lights it shoots up to 2500 revs. BTW i cut out the radio and all the spotlights that were on it when i got it Please Help!!!
 

·
Registered
Joined
·
5,299 Posts
carb model? theres a solenoid on the carb then ups the idle when an electrical load is switched on - quick fix is to unplug it.
 

·
Registered
Joined
·
193 Posts
It's not always possible to diagnose problems online. But one place to start is grounds. These vehicles are notorious for grounding problems.
Chassis ground is the small black wire running from the battery (-) to the chassis only a few inches away. EVERYTHING depends on this one, small ground wire (the starter has its own heavy gauge black wire.) Start by making sure it has a good, solid clean connection. Some owners have added a heavy flexible, braided ground strap from the starter to the nearby chassis, much like other vehicles commonly have. I very much like the idea and plan to add one to mine soon.
 

·
Super Moderator
Joined
·
12,172 Posts
A '91 model will most likely have FI not a carb
Not necessarily - it all depends on the market (country) the vehicle was built for - that's just one of the reasons it's important to include such details when posting a question.
 
1 - 5 of 5 Posts
Top