Suzuki Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a 1998 Suzuki Jimny M/T 1300cc and have noticed an intermittent A/C related problem.
When the A/C is switched ON the engine stalls, runs bit rough (like fuel starvation) and switches off after the a/c has been ON for sometime say for a 30min trip or switch ON/Off manually.
After leaving the car ignition OFF for say 4-5min the engine starts again as if nothing happened. I concluded that it is an A/C problem because in winter I don't experience this problem.
The RPM without load is about 800RPM and with A/C ON is around 1000RPM

Any help please because it drives me crazy in summer :confused:
Thanks in advance for your advise!
 

·
Registered
Joined
·
27 Posts
Try simply adjusting the "HIGH IDLE" BOLT. The high idle bolt comes into effect when the ac and other things like lights are on. Adjusting the high idle should fix the stalling problem.

NOTE: look up how to adjust high idle on the carburetor. It is not a screw its a bolt.


hope this helps
 

·
Registered
Joined
·
5,299 Posts
I have a 1998 Suzuki Jimny M/T 1300cc and have noticed an intermittent A/C related problem.
When the A/C is switched ON the engine stalls, runs bit rough (like fuel starvation) and switches off after the a/c has been ON for sometime say for a 30min trip or switch ON/Off manually.
After leaving the car ignition OFF for say 4-5min the engine starts again as if nothing happened. I concluded that it is an A/C problem because in winter I don't experience this problem.
The RPM without load is about 800RPM and with A/C ON is around 1000RPM

Any help please because it drives me crazy in summer :confused:
Thanks in advance for your advise!
The aircon sends a signal to the ECU which tells it to increase the idle speed, you should check the connections on that line and also test for short circuits. Also check all round the earth connections a bad earth can cause all sorts of issues. The Jimny service manual is available on line if you hunt about for it.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
The aircon sends a signal to the ECU which tells it to increase the idle speed, you should check the connections on that line and also test for short circuits. Also check all round the earth connections a bad earth can cause all sorts of issues. The Jimny service manual is available on line if you hunt about for it.
Hi, Thanks for your reply.

Yes infact the ECU triggers the idle speed when switching on the FAN, A/C, Lights, Power steering etc.. Speed always stays between 750/800 (Off load) and 950 with load.
Also have a copy of the full service manual, I tried to look-up but found nothing relevant to this fault. I thought maybe someone might have faced the problem already.
It might be difficult to locate / access all earthing wiring no? :confused:

The strange thing is that the engine does not stall immediately when the A/C is switched ON, but only intermittently and only when the A/C is used or just have been switched off like no more than 5-10mins ago.
I was trying to trigger it but it won't happen lately while in short trips / safe area but it just happens when you are driving where you dont want your engine to stop !!! :( :mad:
 
1 - 5 of 5 Posts
Top