Suzuki Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi, my Suzuki Jiminy has started makin a strange grinding noise when in 2 wheel drive, soon as i put it on 4 wheel drive it stops! The noise is intermittent, sometimes does it, and sometimes not, but never makes it in 4 wheel drive mode.. I have had into 4x4 specialists and even the suzuki dealer and they can not find the fault, any help is appreciated !
 

·
Registered
Joined
·
9 Posts
dont know about grinding :confused:

but have you tried running with the front prop disconnected?
the front output shaft bearing in my Samurai t-case went and made funny noises in 2wd, but not in 4wd because of the tension on the prop when it is engaged. i've had it do the same thing with broken UJs as well but grinding doesnt sound good.

may be worth taking the front prop off and seeing if it makes a difference...?
depending on the main dealers i would've thought they'd check UJs and such
if with the front prop off it still makes the noise i'd look at the front axle, if it stops i'd look at the tcase output and the prop UJs...

also does your jimny have auto locking hubs?
 

·
Registered
Joined
·
3 Posts
Hi, my Suzuki Jiminy has started makin a strange grinding noise when in 2 wheel drive, soon as i put it on 4 wheel drive it stops! The noise is intermittent, sometimes does it, and sometimes not, but never makes it in 4 wheel drive mode.. I have had into 4x4 specialists and even the suzuki dealer and they can not find the fault, any help is appreciated !
Hi. I have a 2008 Jimny Sierra, Australia, 5 spd manual. It made a noise on acceleration in 3 & 4 gears, 2WD. Eventually fixed by changing 2 gears as a matched pair, and the chain, in the transfer case. Good luck..!
 

·
Registered
Joined
·
1 Posts
Hi, my Suzuki Jiminy has started makin a strange grinding noise when in 2 wheel drive, soon as i put it on 4 wheel drive it stops! The noise is intermittent, sometimes does it, and sometimes not, but never makes it in 4 wheel drive mode.. I have had into 4x4 specialists and even the suzuki dealer and they can not find the fault, any help is appreciated !
Hi,
I am encountering the exact problem, changed my differential oil, seals, 4 small bearing on the front wheels and the noise is still there, can you tell me what you did to solve the problem.

Many Thanks
 

·
Registered
Joined
·
2 Posts
I have a 2006 Jimny with only 100000km. The gear box is shot.Sounds like a cement mixer.The zook has never been off road and driven carefully.Any of you had the same problem?
 
1 - 5 of 5 Posts
Top