Suzuki Forums banner
1 - 10 of 10 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I have a 2016 Suzuki escudo(vitara) I had a bad cooling fan then after that and I started to get a heavy idle and a loss of power when reversing up inclines. It doesn't move at all but on flats it does reverse. I have replaced the cooling fan so far, the throttle body so far has been ruled out. Another problem is the car heat meter is a stroke or two above half which suggest the engine may be getting too hot. Can I get help?
 

·
Registered
Joined
·
9,666 Posts
Which engine and transmission

You have no drive at all?
And what is a heavy idle?
 

·
Registered
Joined
·
442 Posts
Have you determined if the head gasket is compromised ?
Take a look at the engine oil on the dipstick. Does it look like cream ? Also check the radiator cap (when the engine is cold).
 

·
Registered
Joined
·
9,666 Posts
Edited post, Sorry, already asked if it drives in all gears and not just reverse
 

·
Super Moderator
Joined
·
15,802 Posts
It moves in all gears but in reverse on an incline the rpms don't go pass 1000 and it doesn't move. On a flat road it takes a while to catch
Accurate details are critical, especially since we are not there to see what is happening.

If you had a transmission related issue, the engine rpms would be going over 1000 rpm without the vehicle moving - the engine doesn't know whether the transmission is in drive or reverse - so, you would have to be experiencing come form of problem when trying to move forward, which I don't see any mention of.

What is your experience with motor vehicle repairs?
 
1 - 10 of 10 Posts
Top