Suzuki Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
My ESP light has started to appear after 10 minutes into most drives.

Can anyone give me an idea what checks I should be doing to cure the fault please
 

·
Registered
Joined
·
5,945 Posts
tyre pressures first, and have you just had a new tyre fitted in the last few weeks?
Then start diagnosing, get codes read and see what ones you have and report back.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
OK Tyre pressures are good and I bought me a simple plug in tester and it has come up with a UO140 fault code.

what else should I check.
 

·
Registered
Joined
·
5,945 Posts
Thats a BCM comms failure code. This gets set when the BCM loses communications with the engine ECM usually, but believe it or not, a comms failure between the HVAC module and the BCM will set this code as well. It sounds like the Can Bus has an issue between the ABS, ECM and BCM. Clear it and see if it comes back This code usually brings up a check engine light, not the ESP light. If it does come back and is a valid code then this will more than likely require require the services of a diagnostician with a scope to be able to look at the CAN H and CAN L lines when the vehicle faults.
Couple of simple things, check all the plugs on the ABS, ECM and BCM for tightness and any signs of corrosion, and measure power supplies to these modules.

Any other symptoms when it does bring the light up? like a miss? shudder? Anything else in the car not working properly? Like central locking, dash instruments? A/C working ok?

It could be a faulty BCM but 90% of the time is a corroded wire or a bad connection to the BCM on the CAN bus lines.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
I did clear the fault code and it came back. when the ESP appears,Nothing wrong with central locking or A/c. But The Dash instrument light comes on and goes out randomly and left or right indicator randomly flickers..
 

·
Registered
Joined
·
5,945 Posts
I did clear the fault code and it came back. when the ESP appears,Nothing wrong with central locking or A/c. But The Dash instrument light comes on and goes out randomly and left or right indicator randomly flickers..
Flickering dash lights? I'd be checking all connections and power supplies first. Check all ground connections up under the dash and around the fuse box too.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #8
Thats a good suggestion. Power supplies and all ground connections up under dash and around fuse box.
 
1 - 8 of 8 Posts
Top