Suzuki Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello there,

My car has some problems, 1 month ago I change the battery because was not working anymore. Now seems has the same problem but all the lights are working.
the car run off when I press the accelerator and the car does not get more of 40 miles /hr. I thought was the alternator , what do you think?
It shakes sometimes when I stop on a light.

Thanks
 

·
Registered
Joined
·
19 Posts
Does Rev high when you max out at 40 mph?
Edit: to check the alternator start the vehicle pop the hood and take the negative cable off. If the motor continues to run your alternator is good and keeping the engine running. When was the last time you did a tuneup on the vehicle?
 

·
Registered
Joined
·
8,401 Posts
Stop, stop, do not pull battery cable off , this is a sure way to fry your computer...

May have been OK in days before puters...
 

·
Registered
Joined
·
28 Posts
Does Rev high when you max out at 40 mph?
Edit: to check the alternator start the vehicle pop the hood and take the negative cable off. If the motor continues to run your alternator is good and keeping the engine running. When was the last time you did a tuneup on the vehicle?
NEVER DO THIS ON MORE RECENT CARS!!!!

As mentioned above, this is a way to really cause damage to your vehicle. And these Verona's are more susceptible to electric problems than any other car out there. You need to have your alternator tested, many times it is what causes your battery to die.
 
1 - 4 of 4 Posts
Top