Suzuki Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1 (Edited)
So I have had a rash of problems over the last two days. First the power wire to the in tank fuel pump came off and had to solder it back on. Second had the ignition cylinder push out and not turn. Then today on the way home the engine will stutter at WOT. Every gear if you put the pedal to the floor it gets to around 3-4000rpm and stutters. So I pull the bottom plate under the steering wheel and find this button. It does not light up and does not seem to do anything but after finding it I go for a drive and the stutter is gone and drives like a bat out of hell. So does anyone know what this button is and could it have caused my running issue. The wires coming from the button are both black but connect to a coupler and turn into black with green tracer and another black. Also my fuel pump was very noisy before when it would stutter and now it is quiet. Btw my Sammy is a 94 tbi bone stock with a/c.
 

Attachments

·
Super Moderator
Joined
·
12,250 Posts
Mmmm - I could be wrong - but I think that is supposed to sense the key in the lock for a "key reminder alarm - a beeper that goes off if you open the driver's door with the key in the lock & the engine off.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #3 (Edited)
I thought it might have to do with a door alarm buzzer type thing. But it was just hanging under the dash. The white button actually pushes in and out. I cannot see where it would attach. It has two small holes for screws. But your idea sounds like it could be it. However there was no audible alarm with the key in and door open. So don't know.

However the door switch doesn't work the dome light so it might not work the alarm either. Have to check on that wiring.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #4
So after your suggestion I checked with Acks wiring diagram and found that it most likely is the door warning switch. The wires are the same color. And being that it is tied to the door switch which does not currently work that makes sense as to why the audible warning doesn't work. Now as to why I had the intermittent stuttering at wide open throttle.
 

·
Super Moderator
Joined
·
12,250 Posts
IF I'm right - it's not a "door push button sensor" - it mounts to the side of the ignition switch barrel and senses when the key is in the ignition switch - it works with the driver's door push button sensor to sound a beeper.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #7
So you were right Fordem. I found where it mounts. On the backside of the ignition switch and it senses when key is in and door is open. Got the door switch to work and then pressed the button and heard the beeping. Then found the two mounting holes on back side of ignition. Now to find some bolts small enough to remount it. So now I have to figure out my running issue. I think it's the fuel pump.
 

·
Super Moderator
Joined
·
12,250 Posts
Again I could be wrong, but small coarse thread phillips head screws, like self tappers - it's been awhile since I took one apart..
 

·
Registered
Joined
·
39 Posts
Discussion Starter #9
I found one that was a self tapper in the ashtray. But it looks like the threads are very fine so I didn't want to force it. Looks like the PO had this dash apart cause screws are missing all over and the wiring is not tied back with the factory twists. So looks like this weekend I will tear down the dash and clean it all up and bolt everything back the way it's supposed to be.
 

·
Super Moderator
Joined
·
12,250 Posts
Coarse/fine is relative and we have no true reference - my memory is not that good, but I think the screw is going into plastic, so when I say coarse, what I mean is, it's not a machine screw, it's more like a self tapper - if the diameter looks right use it.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #11
This actually mounts to the ignition which is metal of some sort. So didnt want to strip it out. If it was plastic then yeah I would just slam it in there and not worry. The PO used all sorts of different screws into the plastic cover. But being that its the ignition and metal and a new one costs $190. I will try to find one that threads in. No big worry. It's been hanging off since I have owned it.
 
1 - 11 of 11 Posts
Top