Suzuki Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
135 Posts
Discussion Starter #1
ok....im bout sick of this....first i get like 3 seperate oil leaks at once....my a/c goes out....and now i have a super strange noise comeing from the motor....i have no idea what is wrong with my forenza....ok ive think i found out where the sound is coming from and it sounds like its from the timeing belt....it sounds like its rubbing against something cause when i push the cover on more (towards the motor) it goes away and when i let go it comes back....i know i said i was gonna try my best to build my car up but i cant keep up with all these strange things going on with it...so if anyone can help me please do.
 

·
Registered
Joined
·
507 Posts
I had a similar issue when I had my timing belt changed. Right after a cold start, there would be this terrible metallic noise coming from the timing belt cover and it would go away. Then it comes back when I drove and it went away once the engine got warm.

For the first problem the timing belt cover was too close the timing belt.

That solved the sound during driving but the metallic sound remained after starting the car cold.

Once I took it back to the dealership it turns out that my water pump pulley was hanging on to its dear life so that was making the metallic noise at start up. So they replaced the water pump and now I start the car without any foreign noises from the timing belt area.

Hope that helps.
 

·
Registered
Joined
·
135 Posts
Discussion Starter #3
ahh ok....mines not making any metallic noise just a scraping noise like plastic scraping.....would it be ok just to take the cover off competely?? or is that just setting up for disaster later on......i cant take it to the dealer cause they dont do warranty work anymore around my area...and i have a CAI on and it will void the warranty so theres no way i can replace it back to stock without finding a whole new stock system...well all i need is another air flow sensor so if anyones got one just laying around that could help me out
 

·
Registered
Joined
·
507 Posts
Uhhh, the CAI should not void your warrenty. I have the BMS intake and my dealsership does warrenty work on my car. I would keep the timing belt cover on. If something gets in there and snaps the belt boom!! Your engine is toasted!! Somehow debris always gets into cars lol.

I can't help with air sensor :(
 

·
Registered
Joined
·
135 Posts
Discussion Starter #5
ahh ok well i live in alabama and i either gotta drive all the way to tenneessee or georgia to get anything warranty wise done....but i heard that they arent going to do anything out of state anymore but idk..i might just be shit out of luck but we will see.....and i really really need to get the bms intake....im willing to go ahead and buy it now even though i only have about 500 bucks in my bank...i really want it and im sure it will help the car a bit instead of the specter intake i have on there
 

·
Registered
Joined
·
135 Posts
Discussion Starter #6
You're just so unlucky...That really sucks...lol
indeed it does...all my friends say i better get a different car before there are no more suzuki plants around here....i have been looking at the honda fits....im not the type to want alot of power, more controls what im about i wanna take turns full speed or go down the hills lol...not saying my zuki cant just with the problems its getting i want a car i can be garanteed that will keep some dealerships around -_-
 

·
Registered
Joined
·
135 Posts
Discussion Starter #7 (Edited)


here are 2 links i just filmed of the spot where the noise is coming from...this morning it was gone but now its back and im just really wanting to get to the bottom of this....bad quality since it was on the phone but you can hear the sounds difference which is most important XD but ya any ideas tell me

edit: ive found out it makes the noise only at idle after the car warms up....so ya if that helps anyone that will help me it would help alot
 

·
Registered
Joined
·
86 Posts
I have seen this problem before. There is a new Technical service bullentin (TSB) out about the timming belt rubbing against the timing cover. Also have seen this were the noise is due to timing belt slapping because the tensioner is weak. Both of these invole taking off the timing cover to check. Also the a other TSB is about the old style water pump rubbing on the timing belt and cuts the belt. you need to get the timimg cover off and check for these problems. Worst case senario is belt breaks and all the valves get bent due to the engine being a interference motor. I know this is ot great news but i hope it helps.
 

·
Registered
Joined
·
135 Posts
Discussion Starter #9
damn and im not motor savy enough to do something like that lol....i gotta take it to the shop here in a few days to get my A/C hose fixed due to the fans falling on it...so hopefully my belt will last till then....im hoping its just noise and nothing big...thanks for the help though if i get it fixed and everything goes ill be much happier about keeping it lol
 
1 - 9 of 9 Posts
Top