Suzuki Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
I know that there are previous posts in prior years but I noticed most did not get resolved.
I have 110,000km on my 2004 Epica and it has started to idle rough and hesitate when accelerating from a stop. The hesitation will sometimes last a few seconds and then the car goes. Scary when making a left on busy street. I have tried the do it yourself spray to clean the throttle body. Air filter is clean. Oils is changed every 5,000km by dealer. I have not changed plugs or the fuel filter. From reading other posts, the problem did not go away after changing those parts.
I do have a new head with about 11,000km. The car idles great in park.
I want to take to dealer but don't want to change a bunch of parts that won't solve the problem. On the highway, the car runs great and I have not noticed any gas milage decrease since the car was new.
Thanks for any suggestions.
 

·
Registered
Joined
·
388 Posts
For the most part a tune up every 30K miles or about 50K Klicks should be done. But it sounds like you are loosing it on accel so look at the condition of your harness for the coils and fuel injectors. Look for exposed wire in there. If so, you need a new harness.
 

·
Registered
Joined
·
7 Posts
You may also want to look at your gas cap.I know it sounds silly but if it is leaking it could cause a ruff idle, and check all your vac lines for hardness and cracks and replace them.
 

·
Registered
Joined
·
388 Posts
You may also want to look at your gas cap.I know it sounds silly but if it is leaking it could cause a ruff idle, and check all your vac lines for hardness and cracks and replace them.

UH, HOW????

In normal operation the only way from the fuel cap to the engine is through the fuel pump or the evap system. And going down the road it is normal for the vent valve to the gas tank to be open drawing fuel and air vapor into the intake via the Evap Purge Valve.

That is why they have lights on some cars for them just to tell you it is a problem cause there are NO symptoms.

Now vacuum leaks are a valid point
 

·
Registered
Joined
·
15 Posts
Discussion Starter #6
I can't find any exposed wires in the harness. Car has not stalled or hesitated since my first post (driven about 300km). But I didn't mention that the erratic idle happens right after I fill up the gas tank. I fill up at the same station and catch the same red light when I leave the station. At that light, my car will idle rough and nearly stall. Sometimes I turn off ignition and restart, and problem goes away. BTW, I have had my fuel gage sensor replced.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #7
Couldn't find anything wrong myself. The check engine light finally came on, so I took to the dealer. The car blew black smoke and chugged all the way to the dealer. Dealer ran diagnostic and came up with some burning lean code. They said that they updated the software and now no problem. The car passed clean air easily. Does this sound as a simple software issue or do you think I may be up against new computer board soon? Any thoughts would be appreciated. Thanks
 

·
Registered
Joined
·
15 Posts
Discussion Starter #8
Good Bye. The car started hesitating and stalling again. Leaks oil after having oil pan gasket changed again. Needs rotors again after 20,000 km. I just got back from Ford where I traded it in for $3,500. Bought a new Escape 0% financing. Thanks to all that have helped in the past but I could take no more of this car. Cheers.
 

·
Registered
Joined
·
4 Posts
rough idle

i have a 08 forenza i just replaced the cylinder head, timing belt, timing belt guides and pulley, plugs and wires and power pack. the check engine light some times comes on and flashes and it idles rough and may or may not after a minute stall. i cant figure out what is going on. if i unplug the tps and open the choke a little it will run pretty good but then i have no accelerator pedal.
 
1 - 9 of 9 Posts
Top