Suzuki Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
hey so i just wanted to get some input as im not too familiar with these sidekicks yet..
so i got the 1.6 8v, 5speed, 4wd 92 kick. great rig. but runs rough. im averaging about 18 mpg :huh: and i know it can do better. i did a basic tune up with some plugs and wires and set the timing as best as i could, previous owner "timed it by ear". the problem is the clutch fan is tied up cuz there is a hole in the radiator :lol: so i cant get it to full op temp when timing. the motor shakes, can be felt through the shifter, and its got NO power :confused: when i get a new rad ill finish the timing end but is this typical of these 1.6l Zukis? or is there possibly more issues that the pcm isnt detecting?
 

·
Registered
Joined
·
5,299 Posts
The ECU/PCM only detects a limited number of emissions related problems so you could have all number of issues. I would start by repairing the radiator, warming it up and doing a compression test to ensure that the engine is sound. To time the engine you need to use a jumper in the diagnostic socket, if you don't know how to do that then you can download the Vitara (as it was called outside the US) here:

http://www.rhinoman.org
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
Thanks. I am familiar with the procedure and diagnosis of further issues. I'll get there eventually. Lol. But are these things typically so gutless? I've heard the samurai's are... but I figured it would at least pull its own weight up a hill? I found a rad. Be ordering it soon. Currently have timing set for 8° btdc at a 800 rpm idle. It only warms up to 1/4 way on gauge. Not enough I'm assuming. Another mod I found about, the t case was swapped for a newer one... 60 mpH = 3500 RpMs... low geared. Lol
 
1 - 3 of 3 Posts
Top