Suzuki Forums banner
1 - 1 of 13 Posts

· Registered
2013 Grand Vitara JX 4WD 2.4L
9 Posts
Finally, the two fobs are working!

Looked on-line for an answer & took remote #2 apart for the umpteenth time - although several times I had pushed the electrical contacts out to get better contact with the battery, that wasn't the problem. The rubberized buttons weren't aligning properly. When I took the rubber button pad out and tested the metallic under-buttons, everything worked properly. By fiddling with the rubber button pad, I got them to align better and - presto. All is right with the remote world. Dancing. But another thought - the remote wasn't allowing the car to start. So somehow, realigning the rubber button pad also realigned some other contact (other than just the buttons) and allowed the remote to be recognized within the car. Mysterious.
Thanks! This worked for me for my new-to-me GV 2013. One fob wasn't working despite a fresh battery. Opened it up and cleaned thoroughly. It worked while apart, but not when put together. Re-aligned (slightly bent up contacts) and carefully put back together and voila! Nice. I was fearing the reprogram procedure as I also have an aftermarket remote starter and did not want to "de-program" them in the process.

Funny as this is something I do every now and then with TV remotes. They get dirty and need cleaning to improve button contact.
1 - 1 of 13 Posts