Suzuki Forums banner

1 - 20 of 34 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Ok, first problem was at 20,000 miles both rear wheel bearings needed replaced. Now everytime I drive thru wet frozen slush the emissions light comes on in the dash guage. Also the cruise control just stopped working. Anyone else having problems like me. The bad thing is the closest dealer is 3 hours away and of course they have to see the vehicle and then order the parts which require several trips on my part.
 

·
Registered
Joined
·
1,375 Posts
By the emissions light are you rferring to the Service Engine light? And how do you know it is emissions related without scanning the codes (or if you, do post them!!)

I've never seen a wheel bearing fail on an SX-4 personally, and our dealership has sold a lot of them. I would say they must have had a manufacturer defect in the ones that went into your car.

Does the Cruise lights still come on the dash and act "normal" even though it doesn't work now - or has it just quit completely? Is the engine light still on? Possibily the present codes have disabled the cruise. I'd check simple things like fuses and the like first.

Everything should be under warranty still though so even though you may have to make two trips everything should be covered.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
According to the manual the light on the dash is a malfunction indicator light which is provided when it is necessary to have the emission control system serviced. I took that directly from the manual. So I would assume it is emissions related. After the weather warms up a bit and the car thaws out the light will go out. Until I run thru some frozen slush again. The light has been on and off several times over the past months but this is the first time the cruise quit. All the cruise lights come on it just doesn't work. I'll check fuses and see what I can find. Thanks.
 

·
Registered
Joined
·
1,375 Posts
It could be emissions related - but the truth is the engine light can illuminate for anything. The owners manual says "for emissions" because the government probably makes them put that in there.

Your best bet is to have the code(s) scanned and we'll go from there. Even if you go to a local shop or Autozone and have them scan it (BUT DON'T DELETE THEM) we will have a better base to diagnose the problem.
I say don't delete the codes because if you end up having to go to the dealer they won't help you unless they have the codes on their scan tool to see.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5 (Edited)
Found out the problem is a bad knock sensor according to the dealer. And of course he has none in stock and it is out of warranty. Anyone every replace one of these? Or no where on the engine it is located. Looks simple, but of course I will have to have the codes reset to get rid of the light so might as well have a garage do it.
 

·
Registered
Joined
·
170 Posts
the cruise on my sx4 was acting up too. woundn't set sometimes. i found out it was the brake switch wasn't sitting properly in the bracket, i noticed this because i noticed one night iwas driving around with brake lights on all the time.. all i had to do was rescure switch in its proper place and i was good to go..
 

·
Registered
Joined
·
10 Posts
Discussion Starter #8
Well if I did get a dud I'm stuck with it. Went to several dealers looking for a trade and they offer me $4,000 less than what I owe.
 

·
Registered
Joined
·
170 Posts
as it turns out that knock sensor is becoming a common problem. it has to do with the way wire is routed. the wire has a plastic shield around it and where it goes through the firewall it dips, water collects in there and eventually gets through the insulation causing a P0327
 

·
Registered
Joined
·
235 Posts
Its called a diagnostic test. Every dealer does it and $60 is actually cheap compared to other dealers.
agreed. Once you're outside the basic warranty, anything not related to powertrain repairs (still covered till 7y/100k) is customer pay; so a diagnostic fee is pretty standard and $60 is a lot less than we (and most other shops) charge. As suggested above, have a parts store read (and NOT clear) the code, and maybe dig around a little yourself before paying a shop to diagnose it. Anything in the category of Evaporative emissions system leaks try just tightening the gas cap and clearing the code before paying for diagnosis. Don't buy anything until you're sure a loose gas cap isn't to blame (for Evap leak codes).
~Erik~
 

·
Registered
Joined
·
5 Posts
A/C Down...... what to do ?

Hi, my SX4 crossover is white 2007 AWD model and today my A/C failed maybe the compressor is over, what do i need to do ? go to the dealer ? it is under warranty yet ? by the way my car has 16565 miles and 3000 were from Miami to San Diego without any problem, but today the a/c let me down :mad: even worst today we had 103 degrees in Escondido, CA.
Waiting for advices,
Thanks..
OZ



Ok, first problem was at 20,000 miles both rear wheel bearings needed replaced. Now everytime I drive thru wet frozen slush the emissions light comes on in the dash guage. Also the cruise control just stopped working. Anyone else having problems like me. The bad thing is the closest dealer is 3 hours away and of course they have to see the vehicle and then order the parts which require several trips on my part.
 

·
Registered
Joined
·
235 Posts
yes, a 2007 SX4 with 16,500 miles should still be covered under warranty. There is a bulletin about the A/C compressor clutch failing and being replaced by itself (i.e. not with the whole compressor), so without looking at the car myself I would bet that's a good chance of being the case. Either way, yes, go take it in. The sooner you get problems repaired the better off you'll be.
~Erik~
 

·
Registered
Joined
·
180 Posts
Hi, my SX4 crossover is white 2007 AWD model and today my A/C failed maybe the compressor is over, what do i need to do ? go to the dealer ? it is under warranty yet ? by the way my car has 16565 miles and 3000 were from Miami to San Diego without any problem, but today the a/c let me down :mad: even worst today we had 103 degrees in Escondido, CA.
Waiting for advices,
Thanks..
OZ
It is under warranty and this is not the first failure I've heard of.
 
1 - 20 of 34 Posts
Top