Suzuki Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1 (Edited)
When I got my Reno, it already had an alpine system and wiring for an amp/sub. I managed to get ahold of a cheap sub and got everything hooked up properly and there was no power. I checked under the hood and there's a 'square' clear plastic case where a fuse should be. The top part of the square easily comes off and it looks like some sort of square fuse (diagram A) would just slide in. I've done research online and cannot find the same square block. They all seem to be efx (scosche) and ovalish.

There's no screws (or holes) to indicate it would take wafer fuses. I will goto the auto store and see if I can find anything, tomorrow morning. I'm posting here first in hopes I get a response before then so I can know what I'm looking for. If all fails, i'll get a picture on here so u guys know better of what im talking about.

Oh, and i connected the two ends with metal and the sub does work, so at least I know where the issue is, hehe.


Here goes, i hope i can do this lol.


Diagram (A)

··········|¯¯¯¯¯¯¯¯¯¯|«----Top piece that comes off ez.
··········|__________|

··········|¯¯¯¯¯¯¯¯¯¯|
====[¯¯¯|·····|¯¯¯]====wire-2-amp====»
·········¯¯¯¯¯¯¯¯¯¯¯¯

The wires are crimped in and there is nothing between them, just a place where a T looking block could fit. The [¯¯¯|'s are metal.

Hope this shows up well, if not i'll just edit :D
EDIT: ignore the ··········'s

Thanks,

-Fade
 

·
Registered
Joined
·
31 Posts
Discussion Starter #2
i'm a noob :D
i was looking at the right fuses all along, just didn't realise the size difference. i'm used to much smaller fuses hehe. but it's workin now!
 
1 - 2 of 2 Posts
Top