Suzuki Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
61 Posts
Discussion Starter #1
So today I went outside to let the samurai warm up and she seemed to be smoking. I peered under the hood and saw nothing So I drove home quickly to pop open the hood and see what the issue was. I had what looked like fluid spray out of the dipstick and there was fluid on top of the diff, etc however this fluid does not smell like water or coolant but is clear. I then shut off the samurai and it continued to run I had to slide the intake off and plug the intake with my hand to get it to shut off. I am assuming there is fuel getting into the engine where it does not need to. Also my breather tube after I got it shut down had smoke come out of it. Would this be a jacked up fuel pump? This has never happened to me before.
 

·
Registered
Joined
·
616 Posts
Need some info for an answer:

Did you check the dipstick for oil level? If so was the oil noticably thinner and was there more of it than expected? This would indicate that fuel is getting mixed in with the oil - a sign of a damaged mechanical fuel pump.

Do you have a mechanical fuel pump - located on the rear of the head on the intake side?

Was the engine "Dieseling" - ie running very roughly with the ignition turned off? A way to test this would be to pull the center wire on the distributor cap should the problem happen again. Removing that cable will stop electrical ignition but will not stop "Dieseling".
 

·
Registered
Joined
·
61 Posts
Discussion Starter #3
I think I may have found my issue and hopefully I did not toast the motor although I think I did. Underneath the intake you have the tube which is I am guessing a coolant tube? it connects to the bottom of the intake. hose busted and I believe dropped all my coolant everywhere. Hopefully she is not completely done for :( It was running rough when I shut it down. The oil looked good too.
 
1 - 5 of 5 Posts
Top