Suzuki Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
just got a 92 samurai, it will start if I put fuel down the tbi.
will only run until fuel runs out.
installed new fuel pump & filter, tried different ecm from a buddy.
anyone have any ideas or suggestions?
 

·
Registered
Joined
·
29 Posts
Here's a thought or two:
1) Check fuel pump relay if you have one
2) Was the ecm from the same type of transmission? Manual ECM different from Automatic ECM...
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3
maybe I should have mention this is a samurai.
new fuel pump works fine have gas right up to the tbi.
ecm came from 91 samurai so it is the same as my 92
 

·
Registered
Joined
·
29 Posts
oops....you're right...Samurai different from Sidekick...sorry....just trying to help.
 

·
Registered
Joined
·
5,299 Posts
Have you tried pulling codes while cranking? the ECU looks for a feedback signal from the ignition and if it doesn't see it it will cut fueling.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #6
I have check engines with fuse in service slot in fuse panel with ignition on, it give engine code 12 which means everything is normal.
didn't know you could check codes when cranking?
 

·
Registered
Joined
·
5,299 Posts
Cam sensor codes only show while cranking. Have you got a noid light? you should check the the injector is receiving a signal from the ECU.
 

·
Registered
Joined
·
5,299 Posts
The camshaft sensor but you have spark so that should be OK. Did you check the codes while cranking? if that still shows OK then its probably a faulty ECU.
 
1 - 9 of 9 Posts
Top