Suzuki Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have had the problem on my fuel injected Samurai for quiet some time now and i want to adress it.
When the car hasnt run for a day or so it revs to 3000 - 3300 rpm when Cold starting it, i dont really like that when my engine revs so high without oli pressure. I dont really know wich year my samurai is but it has the special plastic fenders and rear Quarter Panels .
Thanks.
 

·
Registered
Joined
·
3 Posts
My '93 had the same problem. I found a thread that explained how to adjust the cold start fast idle valve. Facing the engine on the left side of the throttle body is a triangle cover held in place with 3 small screws. Inside is the valve. The large round washer with tabs is threaded into the housing. Mine was VERY loose and unscrewed(out) almost to the end of the threads. I used 2 small flat blade screw drivers to turn the washer in until it was almost touching the cone shaped piston in the center. The piston is controlled by the coolant temperature.

I turned it in when cold until my idle is about 1200-1400rpm. I like that much better.

If I notice my cold start idle starting to creep back up I will put a small amount of "Purple(222)" thread locker on the washer threads.

Note: After adjusting the washer, you need to put the triangle cover back on before starting the engine to check the idle speed.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3 (Edited)
Thank you so much man, i will try it out tomorrow!
Do you know anything about the special plastic fenders and rear Quarter Panels? Like in wich year that was an Option, i can not find the papers for my samurai.
Thanks
 

·
Registered
Joined
·
3 Posts
Thank you so much man, i will try it out tomorrow!......
YW(hope it helps)

Do you know anything about the special plastic fenders and rear Quarter Panels? Like in wich year that was an Option, i can not find the papers for my samurai.
Pics?

Mine are all metal. Someone here should be able to help, VERY knowledgeable members. None of my Suzuki broachers list plastic fender flares as an option.

:cool:
 

·
Super Moderator
Joined
·
13,745 Posts
I'm pretty certain those weren't a factory option.

If you're trying to determine the year of manufacture, PM me the VIN and I'll see what I can dig up.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
I'm pretty certain those weren't a factory option.

If you're trying to determine the year of manufacture, PM me the VIN and I'll see what I can dig up.
Hey, where can i find the vin on thoose samurai's?
Thanks.
 
1 - 8 of 8 Posts
Top