Suzuki Forums banner

1 - 1 of 1 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey guys, I have just got finished reassembling my 87 Samurai after painting and I have been having one hell of a time getting it running again. First of all this is the first large carbureted engine I have worked on, all my other toys are either EFI or diesel. To start I think its best to give a complete overview of what I did since somewhere along the line I created my own problems because the truck ran fine (stock) before I started on the project.

My initial plan was to disassemble as little as possible in order to paint the body so I unbolted the body from the frame, removed the engine components from the firewall and engine compartment, and lifted the body off the frame, leaving everything attached to the frame intact and taping off all unhooked lines and hoses. I quickly realized that with all the sanding and body work that needed to be done it would be better to take it all apart. After a month working on and off, the body was painted and I decided to paint the frame while it was accessible.

I hung a come-along from a tree and hooked it to the motor using the hook on the front passenger side of the valve cover and the hook on the driver side of the transmission. I unhooked the remaining hoses and lines, unbolted the motor mounts and lifted it off the frame. I covered the engine and left it alone until I was done painting the frame, then I lightly power-washed the engine, being careful not to get water around the carb or the back of the transmission. I put the motor on the frame and hooked everything up that I had taken apart.

Once I had the wiring harness put back on the body of the truck I put the body back on the fame and put the dash, pedals, steering column, and shifters back in and hooked up all the wires inside the vehicle. Next I connected the wiring harness to the motor along with the brake, fuel, and coolant lines, which were flushed or bleed before being reinstalled. I decided I wanted to paint the valve cover while I was at it so I removed it, temporarily covered it with one from another motor and painted it. When I went to put it back on I found that if I did not move the distributor I would scratch the paint. Knowing I needed to recheck the timing I loosened the distributor, as you would to set the timing (I did not remove it) and put the valve cover on, moving the distributor back to where it was. I had a rubber gasket on the valve cover instead of the cork one so I just cleaned it and did not replace, since then as per instructions from the guys at Xtreme Zuks who are in town I have sealed the gasket with Ultra Grey High Torque.

I went to start the motor and I got nothing, I thought maybe there was a blockage at the needle seat screen in the carb so I sprayed some carb cleaner in it and lightly blew it out with compressed air, but still nothing. I figured it was not getting fuel because of the air in the lines so I primed the line, pulled the gas line off the carb and looked to see if it was pumping fuel. It turned out that for some reason the fuel pump was not functioning so I swapped it out for the one on my other motor sealing it back up with ultra grey. I tested the donor pump and it functioned properly at about 3-4 psi as I recall. Hooked it back up and got it to start and idle. I reset the timing to 10 BTDC and tried to move the truck. As soon and the body tilted slightly the engine died. It would sputter, backfire, and die, and I would have to wait awhile before starting it before I could move another 30 yards. I assumed the engine was flooding maybe because the compressed air changed the float height. So I reset the float as per Haynes manual and realized that the screen on top of the needle seat was gone so I replaced it but could not find the old screen. Tried it again but no improvement so I checked the float height again and realized the new screen was gone, nowhere to be found. I did not replace the gasket either of these times as it was in good condition do my problems sound air leak related?

The truck still did not run so I turned to Xtreme Zuks for some advice. The guy told me that my problem was the carb because it is a piece of junk and the solution is to trash it and buy a Weber. After messing around with it for a few more days I buckled and bought a new 32/36 DGEV Redline Weber kit a GM alternator and new spark plugs. I removed the old carb and all of the emission control stuff and put the adaptor plate on the intake. The manual for the Weber said to use grease or another suitable gasket sealer on the gaskets. Xtreme Zuks advised it use none but I read on one forum that armorall worked well so I tried it and used blue locktite one the bolts and studs. I tested the adaptor for leaks when I was done and sure enough it was leaking air. I found I had spun the studs when I put the nuts on which caused the leak. I reset with them with more blue locktite and used plain old bearing grease on the gaskets. Still spun the studs and got a leak so I took the top plate off and used red locktite on the studs and let it dry overnight. I found some gasket dressing and sealer in one of those little packets by the register at Advance and the guys told me it would work so I coated the gaskets with it this time but it appeared to be a silicone product, which the Weber instructions say not to use. There was no getting it off the gaskets so I just finished the job and put the carb back on using red locktite on everything except the nuts where I used blue. No major leaks this time, when I spray carb cleaner around it once in awhile you can hear very very slight change in idle but much less than before and not as much on the adaptor plate as when I spray it right at the plugged vacuum ports. Do the plugs for the vacuum ports need zip ties or clamps? The new carb has an electric choke, which I ran to the positive terminal on the coil as per Xtreme Zuks instructions and I looped the two water lines together. Shouldn’t I have to ground the carb for the choke to work? The throttle cable has some slack in it to allow the lever to set all the way back is this correct? I turned the mixture screw in until it was seated and then backed it out two turns and adjusted the idle seed screw until it just touched the lever. When I start the engine it will idle fast as it is supposed to at first to warm up and then I press the gas and it will idle back down and slowly die. I can only get it started back up when I pump the gas a few times and when it fires I have to run out and grab the throttle cable to keep it going. I have to back the mixture screw out to about three turns from seated until it idles on its own. Is this too much, could the idle jet be too small as the manual suggests? When I press on the gas after it has been idling for some time the engine will hesitate at first but then rev up and down and go back to idle but every once in awhile it will die out but I cant tell if its not getting fuel or choking somehow (the choke plates stay open). I can drive the truck but it always seems like I am not getting enough power so I turn the screw in a half turn and it drives better but idles worse and dies more often. I also have to pump the gas pedal a few times to get the engine started again. Is it normal to have to pump the gas pedal to get the engine started with a Weber? Is there anything else I can adjust? I have done a compression test and rechecked the timing, the fuel pump works but I don’t have a pressure regulator as the Weber manual suggests. Do I need a fuel pressure regulator? What is an acceptable pressure?

Some other questions I have:
I put a new windshield in myself and am having problems getting the passenger side of the rubber flap to lay flat does anyone know a way to move the glass over some to get it centered with three sides of the rubber on?


Thank you all who have taken the time to read all this
 
1 - 1 of 1 Posts
Top