Suzuki Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
When I first go over 55mph, the rpms will jump from around 2000 to 4000 for a second then go back down. When this happens, the car begins to slow down but then goes back to normal and picks up speed again. Any ideas what this could be? It only happens when the car goes over 55mph from cold. Doesn't happen again during same trip. I just put some Lucas Oil Deep Clean fuel system cleaner in hopes that it will fix the problem. Could this be a transmission issue instead?

2006 Suzuki Forenza

Thanks for any ideas.
 

·
Super Moderator
Joined
·
12,258 Posts
I would suspect the transmission, or a transmission related issue.
 

·
Registered
Joined
·
3,098 Posts
hi Krst298 welcome to the forum! ok first does this happen every time you hit 55 or just the first time you hit 55? it could simply be the trans hunting for the right gear, then downshifting to the correct gear.
also pretty much all the fuel system cleaners dont really do much. the fuel pump doesnt run the pressure required to clean the system and theres also not a strong enough cleaner in the mix. if there was your car wouldnt be able to run on the fuel lolol. if you suspect an issue have it checked. there are places you can go to have the fuel injectors checked/cleaned. sometimes they can get clogged. let me know
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
hi Krst298 welcome to the forum! ok first does this happen every time you hit 55 or just the first time you hit 55? it could simply be the trans hunting for the right gear, then downshifting to the correct gear.
also pretty much all the fuel system cleaners dont really do much. the fuel pump doesnt run the pressure required to clean the system and theres also not a strong enough cleaner in the mix. if there was your car wouldnt be able to run on the fuel lolol. if you suspect an issue have it checked. there are places you can go to have the fuel injectors checked/cleaned. sometimes they can get clogged. let me know
Thanks for the information. It actually started doing it at a lower speed, 40mph and it only does it once during a trip. It's at a transmission shop right now. They say it's hanging up in 3rd gear. Looks like their fix will cost more than the car is worth.

Thanks.
 

·
Registered
Joined
·
3,098 Posts
hi wow sounds rough. transmissions can get expensive. did you check with a dealer and see if the car is still under the power train warranty? i think they can check over the phone if you give them the vin.
 
1 - 7 of 7 Posts
Top