Suzuki Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
Hello people, I'm back. currently stuck in Austin TX, not really stuck, but I live in NYC, don't want to get stuck on the way back home. I flew down from NYC to Arlington TX, cuz I found a 86 sami jx, with 61k on it, it was a trade-in in 1994 from original owner, the guy I've got it from was a mechanic at the dealer ship at the time. I was told by him at that time all it need was a water pump. but he just liked the sami, didn't care to drive it, so it ended up in the back of his barn.
Long story short. we pushed it out, put water in it to see the leak, sure enough, water came right out of the bottom hole of the water pump...so far, its got a new water pump, new rediator(just in case) belts(fan, ac, timing). new wires, plugs, amazingly the ac compressor still had pressure and the tires aren't dry rotted, driver side brake cylinder had a small leak, tail lights goes on and off, anyway it made it to Austin about 200miles, our truck can only go so fast speed limit is 75MPH so didn't have to use my brakes at all...:lol: now I'm at a friends house, trying to make it all work before I try to drive back to NYC. In ATX I used my friend's power washer, blasted everything top to bottom in and out(removed all the carpet seats...etc) this thing had no rust what so ever any where! took the timing cover off, found a mistake I'd made before when I changed my head gasket, the crank shaft seal O-ring was out about 1/8", so I popped it in all the way, no more leaks, ordered and installed a new timing cover. changed the brake cylinders(both side)everything came off like it should due to 0 rust, even the spring are still shinny and new. found a leak on the rear diff(input pinon seal) going to put it in today. also put a new transfer case sheet in, cus it just popped in 4wd on my way out of Arlington TX, but still not going into 2H!!! will be trying the screw driver trick I'd learned this morning, today.
here's the only thing I'm stump about, please help asap! when in idle ready to go from a stop, every time I gas it, it'll choke 1st, if I don't hold or rev it more, it'll stall out. what is it? oh new gas filter, he actually drained the tank before he parked it...
 

·
Registered
Joined
·
5,299 Posts
It could be a blocked accelerator pump in the carb, however, given its history, its worth replacing the spark plugs with new properly gapped items.
 

·
Registered
Joined
·
686 Posts
+1 acc pump. Just lean over the carb and pop the choke open (engine off, key off) and blip the throttle and you should be able to see a tiny jet of fuel squirt into the barrel, or at least hear it.

You live in NYC so I have to assume that the emissions inspections are tight, I also now have to assume your insane for driving there :D

Would an emissions or inspection reveal an aftermarket carb? I'm not sure how sticky they are. (Thinking Weber conversion)

BTW, kudos for the road trip! I live for stuff like that. Of all the places I might get stuck TX does not make the top 10. Are you going to be able to get parts for it there? Perhaps if you drop Trail Tough a call they can overnight you the pieces you need to get back on your way.
 

·
Registered
Joined
·
616 Posts
another possibility could be a leaky vacuum line.

carefully check each line individually for loseness or cracks. To keep from creating problems, test and replace lines one at a time. Auto part stores carry bulk vacuum line. Three feet of it should be enough to replace all of it I would start with the vacuum advance line that runs from the carburetor body to the distributor. Do a search for vacuum at Ack's FAQ (see link in signature, below)

Welcome to the Suzuki Community and congratulations on the Samurai score!
 

·
Registered
Joined
·
22 Posts
Discussion Starter #6
Got 10' of hose ready to put in 1 by 1. somehow the transfer case is acting funny, before I took it off, it'll only go 4H and 4L although it goes in to the 2H slot, but nothing happens, now it'll go in to 4H 4L and 2H but the front drive shaft is not spanning at all, I can feel the difference between 4H and 4L tho. so I took it off the truck clean it, drain it, put thin engine oil in it, drain it, saw a bunch of tiny dusty metal crumbs, and 1 little chunk, so I guess I need to rebuild the case? if so should I get a rebuild kit with a higher 5th gear?(little faster for the return trip)
 

·
Registered
Joined
·
22 Posts
Discussion Starter #7
Ok the strangest thing just happened,the carburetor is working fine now! but I definitely need a transfer case...called a rebuilt guy in CA $300+$40+$40 core exchange, is this worth it? i will want to do a lift and no bigger then 31" tires, should I buy a different gear set? would like to top off @ 75mph @ 3000rpm, ok with 3500rpm too.
 

·
Registered
Joined
·
22 Posts
Discussion Starter #8
BTW there's no emission test for vehicle over 25 years old, even without historical or antique plates...this thing does have stock CAT and Exhaust, in perfect condition...any Californian on this forum need it PM me...just pay the shipping and $100(junkyard would make a new pipe for me), its yours...
 
1 - 10 of 10 Posts
Top