Suzuki Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Guys where is the relay to the rear wiper on a 2005 Suzuki Ignis II 1.5 4grip ?
My rear wiper is stopping and starting all over the place and its not the teeth in the spline or a loose arm.
Is it the actual same relay as the front ? As I can't seem to find a rear one anywhere.
Think I may need to replace it if I can find it.
 

·
Registered
Joined
·
9,356 Posts
The fact its stopping all over the place suggests the park contact in the wiper motor may be faulty, rather than the relay as that only turns the wiper on, when the relay opens, the wiper continues to work until the park switch in the wiper itself operates. if thats not working and is open circuit, the wiper will stop immediately the relay operates.
 

·
Registered
Joined
·
1,067 Posts
I have plenty of spare wiper motors (and relays) in Australia if you have difficulty locating one. We normally do most of our motoring in a forward direction in Australia, so unless you have a rear facing camera, it's not a biggie! ;)
 

·
Registered
Joined
·
12 Posts
Discussion Starter #4
The fact its stopping all over the place suggests the park contact in the wiper motor may be faulty, rather than the relay as that only turns the wiper on, when the relay opens, the wiper continues to work until the park switch in the wiper itself operates. if thats not working and is open circuit, the wiper will stop immediately the relay operates.
Ahh right. Makes perfect sense. Thanks for that.
I'm sure I can pick up a cheap second hand motor from somewhere around here. (y);)
 
1 - 4 of 4 Posts
Top