Suzuki Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I cannot open/unlock the rear door on my 2008 SX4. It used to work fine up until a week ago. When I press the rubber covered button under the door handle to open I can hear a faint click but it acts like it's locked. All the other doors are unlocked. I can lock/unlock all the doors either by the key fob or the lock/unlock button on the drivers door, except for the rear door. I read through all the previous posts, and saw references to spraying WD40 from the inside - sprayed from inside and outside- no change. I checked the manual for a specific rear door fuse and did not see one mentioned. Is this a "only the dealer can fix" thing or is there something I missed- didn't try yet? I appreciate any feedback/advice. Thanks!
 

·
Registered
Joined
·
849 Posts
Ok this is a hathback . Where do you live ? Is temperature a factor (frost) ? rear door (L or R)..or rear doors ?

As ssen on this diagram
www.avigex.ca/sx4/doorlock.pdf
hatch ( (page 2 on the left) and rear doors( (page 2, on the right) have separate circuit...hence your problem is surely mechanical..
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
Ok this is a hathback . Where do you live ? Is temperature a factor (frost) ? rear door (L or R)..or rear doors ?

As ssen on this diagram
www.avigex.ca/sx4/doorlock.pdf
hatch ( (page 2 on the left) and rear doors( (page 2, on the right) have separate circuit...hence your problem is surely mechanical..
Hi...no temp not a problem, live in the south. Yes it's a hatchback, the back hatch on the car, not any of the side doors.
 
1 - 3 of 3 Posts
Top