Suzuki Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi - I have a 2006 Aerio SX - about a year ago the fuse to my radio, gas guage, and dome light kept blowing. After numerous trips to the mechanic and not finding anything, it was determined that they thought it was my cell phone charger. Every time I took the car to the garage I removed my charger to take with me (plugging it back in each time the fuse was replaced), the mechanic would replace the fuse and everything would work. I stopped using that charger. I have used that power source with my GPS with no issues. I had not had any other issues until yesterday. The fuse blew again (with nothing plugged into power source) - I was at a gas pump with my ignition switch set to where just the radio plays and when I got back into my car I heard the 'pop' and the fuse blew. Replaced the fuse when I got home and everything was fine. Made a stop at lunch today - ignition was turned completely off. Started car and 'pop' fuse blew again. I'm stumped. Any ideas?
 

·
Registered
Joined
·
5 Posts
have had issues like this before. Once in a Chevy blazer, the actual radio was the problem. It was hard to find, as a few things are on some fuzes. If it blows all the time, just unhook each part (no bulb in dome) unhook radio ( harder as it require taking apart dash some to remove) etc.. the other was a Van, the Cig ligter was just bad.. nothing plugged into it ,but once it was unhooked from power no more fuze blowing.

try unhooking stuff on that fuze, again not fun, but unless somebody else comes up with an idea. Do it one at a time until it doesn't blow. good luck.
 

·
Registered
Joined
·
1 Posts
Did you figure out the issue? I have the same problem, but my wipers also go out. Were your wipers affected when the fuse blew as well? Thanks, Chris
 
1 - 3 of 3 Posts
Top