Suzuki Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
I have a 89' Samurai with stock carb. Recently, it has been "hiccuping" while driving sometimes, as if one of the cylinders didn't fire. Someone suggested that maybe it's vapor lock.

Anyhow, as I was driving it a few days ago, I hear a loud "POP!" coming from the steering column, followed with a puff of smoke, then the smell of what seems like burnt electronics! The poor sammy "hiccuped" but didn't stall, and I pulled it off to the side of the road. After checking all lights, turning signals, windshield wipers (all working), I started the Sammy and drove home...

As I drove it today, it happened again. A loud "pop!", from the steering column, Samurai "hiccups", and smell of burnt electronics. Again, it seems to drive OK...

What could it have been??

All the fuses are fine.
All lights & instrument cluster seems fine.
 

·
Registered
Joined
·
8,394 Posts
It is never a good sign to let the smoke escape from the wiring, loose gremlins will eventually bite your butt..

... Philip
 

·
Premium Member
Joined
·
1,302 Posts
You need to stop driving it, pull the column down and find the place that is grounding out.
Once the magic blue smoke is released, it is a real bear to put things back the way they were.








Don

.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #5
OK....It looks like there are a ton of wires that go into the steering column? I dropped my column down by removing 2 screws...didn't seem like it can drop further than a few inches.

Are there any electronics in the Samurai that I should be worried about? This car is too old to contain computers right?
 
1 - 5 of 5 Posts
Top