Suzuki Forums banner

41 - 52 of 52 Posts

·
Registered
Joined
·
387 Posts
Trips? I don't see how those would vary that much between the US and Au. :confused:

But it does seem that there are many differences between our cars and yours.

I've never quite understood that.

:cool:
I was referring to the old joke that a cowboy would ride his horse from one side of the street to the other. If that attitude isn't common now then my mistake.

I do not think that there are that many differences, electric power steering, some differences in the lights and wiring and the ride height. I believe the ground clearance came about because the Australian market had a tax break for imported 4 wheel drive vehicles with a minimum of 200mm clearance.
 

·
Registered
Joined
·
2,132 Posts
Yes, it seems that most of the differences between the US and OZ are due to Government regulations, etc.

Me thinks our regulations are much more stringent here. We must have ESP on our cars, seat belts, shatter proof glass, certain other safety equipment and we can't tow.

It's funny though, I saw a Smart Car the other day with a trailer hitch on it.
That was almost comical. Of course, I have a trailer hitch on my SX4 too, despite the Suzuki regulation against it. The car is more than capable of pulling a trailer, so I don't understand the regulation. I've even pulled a double axle car hauler with mine. As long as you have trailer brakes, pulling a trailer is a piece of cake. It's not the pulling that's the problem, it's the stopping. :rolleyes: ;)
The brakes on the SX4 are just not able to stop a heavy load, in a safe distance. I had about 400# in the back of my car one day, and the stopping distance almost doubled.

I'm sorry, we've drifted off topic.

:cool:
 

·
Registered
Joined
·
3 Posts
I bought a 2012 sx4 crossover 5/19/2012 have had it in the shop 3x's for not starting. They have still not been able to resolve my issue. they claim it needs reflashed but say they dont have the software so in the meantime they have been replacing things that are not broken like cam sensor and crank sensor. Other than that I am told I have roadside assistance and they will call when they have more answers...completely unexceptable I filed for arbitration and my date is set for July 10th. Has anyone else gone thru arbitration with suzuki what was the outcome and any advise?
 

·
Registered
Joined
·
387 Posts
I bought a 2012 sx4 crossover 5/19/2012 have had it in the shop 3x's for not starting. They have still not been able to resolve my issue. they claim it needs reflashed but say they dont have the software so in the meantime they have been replacing things that are not broken like cam sensor and crank sensor.
Why would a 2012 need reflashing? That was a supposed answer to an earlier model with a different engine. If that software change was relevant it would have been included at the factory.

Earlier I posted "Once mine doesn't start after a few turns it doesn't matter how long it cranks, the car won't start until the key is turned completely off then it starts OK next try. I think it is immobiliser related not fuel. "

That still happens occasionally. The usual case is Ign on so passenger window can be dropped. If I don't start the engine while farewells drag on, chances are it will crank but not start.
 

·
Registered
Joined
·
643 Posts
I agree with Paul. I think its the immobilizer or at least something along those lines. I have a 09 sport with no alarm or keyless start thingy and haven't had any of these issues yet. All I have is the key fob that I can unlock/lock the doors with.
 

·
Registered
Joined
·
56 Posts
The Key could be failing

I agree with Paul. I think its the immobilizer or at least something along those lines. I have a 09 sport with no alarm or keyless start thingy and haven't had any of these issues yet. All I have is the key fob that I can unlock/lock the doors with.
If it is the security system, have you tried using a different ignition key? The chip in the key is part of the system too. If it is damaged, say by dropping or vibration or by electronic fields in a factory, that could make the car difficult to start.
 

·
Registered
Joined
·
387 Posts
I think the key does its handshake thing and everything is OK then if you don't start within a certain time it resets. A bit like remote unlock will relock if you don't open the door.

The 2010 owner's manual has the following

" If you leave any of the doors open with the ignition switch in the “ACC” position for awhile (and no key inserted), the engine may not start when you turn the ignition switch to “START”. If the engine does not start, close all doors completely or turn the ignition switch back to the “LOCK” position, then start the engine."

Just try starting from scratch rather than cranking for a long period.
 

·
Registered
Joined
·
3 Posts
Why would a 2012 need reflashing? That was a supposed answer to an earlier model with a different engine. If that software change was relevant it would have been included at the factory.

Earlier I posted "Once mine doesn't start after a few turns it doesn't matter how long it cranks, the car won't start until the key is turned completely off then it starts OK next try. I think it is immobiliser related not fuel. "

That still happens occasionally. The usual case is Ign on so passenger window can be dropped. If I don't start the engine while farewells drag on, chances are it will crank but not start.
Thanks for your response. I don't understand the reflashing either, I think it was more of something to say because they dont really know what to do otherwise. I know the key positioning is not my issue nor is it the key because I have used both sets and still had the problem. Just last night I started having issues with the "sport tronic" or manual version of my automatic transmission (not sure what it is called). I was driving down the interstate 60mph moved the shifter into the manual position it was in 5th gear which was causing it to rev a bit so put it in 6th and attempted to accelerate...foot was to the floor and nothing car only maintained its current speed. I tried again later doing 40mph or so and when I shifted into manual gear it initially was starting out in 6th gear at 40mph. I have had these types of tranny's before but they never worked like this.
 

·
Registered
Joined
·
643 Posts
My friend has a lexus and when I go from auto to manual it throws it to the highest gear.

My brother has a 2012 dodge 1500 work style truck and has trouble starting as well. Dealer says they can't do anything since it doesn't do it when he brings it in. Looks like its just not Suzuki. He only has door unlock/lock key fob. No fancy stuff like alarm or anything.
 

·
Registered
Joined
·
3 Posts
Mine doesn't have the alarms and all that either, but what is he doing about it? I can't believe anyone would spend thousands of dollars on a brand new car and accept the fact that it isn't functioning as it should.
 

·
Registered
Joined
·
643 Posts
My brother is just waiting for it to happen more often and writing down the noises and or lights that do and do not come on when it happens for documentation. Its annoying he says. We used to own nissan cars so we are used to junk not working right and recalls every few months that didn't help. On our nissans we had a hard starting issue. You would have to turn the key on and wait three seconds and then start it. My brother had his in the shop a few times for this. The dealers said it was the fuel pump so it was replaced. After a few weeks it started again. We never did get it fixed. But it wasn't just ours. It was all that particular vehicle. Mafs, crank sensor, tps sensor, fuel pump was all replaced on his car looking to fix the no starting issue. Oh well.
 

·
Registered
Joined
·
1 Posts
Problems with Suzuki Celerio

My daughter just bought a Suzuki Celerio more a month ago. While driving the car completely just shuts down and steering wheel locks by time. We have the car tested twice now but they cannot seem to pick up any problems? Anyone know what might trigger this? It happened to her three times already.
 
41 - 52 of 52 Posts
Top