Suzuki Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi guys i am in desperate need of help with my van, it's a 96 supercarry and it gets terrible fuel consumption (45 miles from £10) have tested the engine for compression and adjusted tappets. I did find a leaky inlet gasket which i replaced. Am i right in thinking it should have a catalytic convertor? It doesn't but does have a lambda sensor type thing in the manifold. It also stutters a little under light throttle use but then clears up when you give it half or more throttle. Is there any adjustment on the carb for mixture etc? Or do you guys know any other likely causes of such poor fuel economy?
Thanks in advance
Chris
 

·
Registered
Joined
·
33 Posts
hi i had the same problem with my van when i first bought it. however it is an F6a EFI rear mounted engine. At first i was only getting about 9 KPL. First see if the timing of your van is correct, i adjusted mine to about 12 degrees TDC and runs beautifully and now i get about 15 KPL. if the problem isn't there its most likely the carb. Take out one of your spark plugs to look at its color. If it is sooty black, its definitely running rich. Not sure though on stock settings for your carb though. just bring it to a carb specialist so they can adjust it. If you want to try yourself i usually start off with two and a half turns from it being full tightened. rev it up and check your plugs again. it should be clean with a nice copper color. if the engine can't rev high enough then its too lean. anyway hope this helps
 
1 - 2 of 2 Posts
Top