Suzuki Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I have an 88 Sammy and I am hearing clunking/ grinding noise in the front right passenger wheel. Also, when I shake the wheel, I can move it from front to pack. Feels loose (all bolts are tight) Could this be bearings ? Also when I tried to move my Samurai out of the driveway yesterday (in snow) the 4x4 was not working. Only my back wheels were spinning and got nothing from the front wheels. Please advise, I am a pretty new sammy owner. Feels like my front tire wants to fall off. Are these two issues tied together ? Do I need a new hub or cleaning and new bearings ?

Thank you
 

·
Registered
Joined
·
32 Posts
I'm no expert, but I would say they are tied togather. Could be anything from a front hub shucked out to a broken axle? If it was me I would get it to a repair shop before more damage is done. Just my .02 cents worth.
 

·
Registered
Joined
·
76 Posts
loose wheel is either wheel bearings or kingpin bearings loose or both

grinding noise is probably broken CV (Birfield) or stripped spline on the axle, or broken axle, or broken freewheel hub if fitted

Are you definetly sure its from the wheel? Because the front diff is on the right side. Could be broken teeth in diff gears
 

·
Registered
Joined
·
105 Posts
i've had my front left wheel bearing stuff up and that just made a high pitched sqealing scraping noise i had to keep pouring water on my hub to stop it from siezing as i was a couple hundred kilometers away from home
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
Thanks guys for responding. When I push on the wheel back and forth makes a screeching/ scraping . Again feels like the wheel is loose. And makes the noise the most at low speeds. I havent been driving it because afraid wheel will fall off. Maybe bearings or differntial ? I'm going to have to get it towed to shop. But would like to buy the parts before hand so I dont get ripped off in parts for repair shop. Also anyone else think this is tied together in why the 4x4 is not working now ?

Thank you !!
 
1 - 5 of 5 Posts
Top