Suzuki Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi all,

First off my car is a 2006 V6 Suzuki Grand Vitara.

I ran into some overheating problems over a year ago now and it has been undiagnosed since. Basically I was stuck in traffic one day and noticed my temperature gauge was in the red and pulled over to sort it - having experienced this with previous cars in the past I assumed it was my secondary/radiator fans not kicking in however this was quickly ruled out after a trip to the mechanics. I was told it was going to be a head gasket after some testing however they couldn’t be sure just a few things they found (the mechanic is a good mate and wouldnt go to this outcome without ruling out cheaper options first) when they were starting this they noticed a cracked hose and replaced that and it was okay for a week. Then I was off-road and reversing a very long way and again noticed it was in the red. My second trip to the mechanic noticed that the engine wasn’t actually overheating just the gauge saying it was hotter then what it was. So they replaced the temp gauge and the thermostat for another reason I forget and checked the radiator with a specialist to rule that out as well. After all that it barely lasted a few days before it was in the red again. It was then I noticed the radiator was actually empty and it has pushed all the water from it into the resivour. Realising it was probably a pressure issue I replaced the only thing (I think) not yet replaced or checked - the radiator cap. I went genuine as the one on it was still fairly new but not genuine. However I still have the same problem. I should note this isn’t the problem every drive, just obviously when the radiator is empty and when stuck in heavy traffic or when off road. I love my Suzi but at this point I’m ready to put a free sticker on it and bugger it off - over $2500 worth of repairs and still the same problem. I feel the need after seeing a few posts that the aircon started playing up around the same time and they still haven’t diagnosed that either after 2 rounds of detectable gas however aircon is really something I can live without and get fixed later on.

Thanks in advance!
 

·
Registered
Joined
·
8,282 Posts
Have they ruled out
  1. HG with pressure test or combustion gas test.?
  2. Fan failure? (could be common with a/c)
  3. Flow test on water pump?
  4. Flow test on radiator?
 

·
Registered
Joined
·
445 Posts
And check the thermostat is in the correct way.
When you are adding fluids you may not be getting all the air out of the system.
Engine fan will be very loud on start up then go quiet after a minute or so. And if the radio is off you should be able to hear it kick in now and then, especially sitting at a stop.
Sounds almost as if you just have a bad leak under pressure. Those pesky heater hoses at the back of the motor can be stinkers.
 

·
Registered
Joined
·
20 Posts
Does heaters work properly as in if you put them on full blast do they go cold very quickly. And also have someone rev the engine while you have your hand tightly round the hoses. They should feel as though there expanding and shrink a little again once the revs have gone down as normal. If they they dont expand this can point to the water pump. Just a thought pal.
 
1 - 4 of 4 Posts
Top