Suzuki Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Have a question on my 2007 Forenza. Have an oil leak coming from a valve on front of engine. Goes up to the top of valve cover. Valve it self is not leaking but after a few minutes the valve does. I believe this is a return line for the oil to the pan. Has any one encountered this and if so how were you able to fix it. Not in the mood for a 400 dollar valve cover. I heard of workarounds. This piece as on front drivers side. Part of valve cover sticks out. Any help would be great new to the forum thanks:D
 

·
Registered
Joined
·
3,098 Posts
hi welcome to the forum. there is no valve on the front of the motor.are you talking about the small piece of hose coming off the valve cover to a pipe that runs along side of the oil dipstick? maybe the hose has a hole in it or is cracked? unless your valve cover is cracked or broken in some way you wont need a new one. can you post up a picture or two? that would definitely help.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
oil leak

its the egr hose on older models it is in the block not part of the valve theres a rubber grommet in the cover have to by a whole cover now its only leaks when its cold not very much must be whatever is in the rubber
 

·
Registered
Joined
·
1 Posts
its the egr hose on older models it is in the block not part of the valve theres a rubber grommet in the cover have to by a whole cover now its only leaks when its cold not very much must be whatever is in the rubber
It would be hard to seal it without getting the part. It could not be too much. Are you leaking enough that you have to add oil?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
ive had it for 3 weeks still at the full line must not be leaking that much. Notice a ton when a went to kansas city. That could because of the highway driving and the high rpms.
im not good at posting images this is the engine pic the aluminum hose is at the front right of engine
 

·
Registered
Joined
·
3,098 Posts
sorry there were no pics attached to your post. i think if you go to advanced when your posting thats where it lets you post a pic from
 

·
Registered
Joined
·
3,098 Posts
Hi. Yes that's the part I was originally talking about. It's a pressure/oil return from the valve cover down to the oil pan. There's no valve or anything in there. You should take off the heat shield covering the exhaust manifold and inspect the hose and pipe for cracks or leaks. The heat shield comes off by just taking out a few bolts. It's that big silver piece on the front of the motor there. Let me know what you find out.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #11
that must be why it only leaks after an hour or so no cracks i noticed it leaks at the top where it enters the valve cover theres like a plastic ring berfore it goes in
 
1 - 11 of 11 Posts
Top