Suzuki Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I bought a 2008 Suzuki SX4 from my brother. He, at some point, took the car to a shade tree mechanic and they attempted to replace the o2 sensor with a generic part. When the mechanic replaced the part apparently he clipped the wiring to the point where my mechanic can't see where the original wiring (on the harness) to get the O2 Sensor to work. Can anyone provide any guidance on this issue?

Appreciate any insight that you could provide.
 

·
Premium Member
Joined
·
1,319 Posts
I just took a picture of the heated 02 sensor test information for a grand Vitara, it might give you an idea of what to look for, for your vehicle.

It lists the color of the wires that you would need to find in the engine harness,
and shows their positions in the connector to the ECM.
This is for a GV, you will need to find the FSM for your car.

On my GV, the wires came out of the engine harness near the wires going to the Throttle body. It would probably be a good place to start unwrapping and looking for the cut off wires.

Wire colors are listed as R, GR/Y, R/BL as an example.
I am not saying those are the colors of yours.
I only mentioned them so you will know what to look for in your FSM.




Good luck.

Don

.
 

·
Registered
Joined
·
839 Posts
Mjvincent..please fill up your profile so in the future, we will not ask again where you live, the exact model , engine type, transmission, etc, of your car.., in order that proper information can be provided. There are several models and engine types over the world....
 
1 - 3 of 3 Posts
Top