Suzuki Forums banner
1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi my 2001 grand vitra 2.0 td has no power
It is saying low fuel on the dealers diagnostics,they say their is nothing wrong but it wont kickdown and wont go above 40 mph.

I am going to change the fuel filter to eliminate that any suggestions please

Thanks Kevin
 

·
Registered
Joined
·
65 Posts
well.. i am having the same problem with my 02 J20 vitara

After replacing fuel filter, coil packs, advancing timming, cleaning the TB and changing plugs still low on power.

I also used Seafoam on the fuel, oil and thru the intake mani to remove any carbon deposit.
Changed both O2 sensors, CAM sensor and replaced the front cat....still no power.

I am seriously thinking on adding some sort of standalone ECU to tune the engine myself.

I am clueless here!!!
 

·
Registered
Joined
·
23 Posts
Have you done a compression test? Has the engine run with a K&N or other "high performance" air filter?

I had a '98 Sidekick Sport (1.8 litre version of the J20) that had a K&N for the 2 years before I bought it. The guy was selling it because it was starting to feel "tired." The K&N had passed so much dust that the cylinder walls were worn worse than my Tracker engine after 400K.

Use factory equivilant filters! Oil bath filters went out in the 50's!
 

·
Super Moderator
Joined
·
18,978 Posts
Wow. You've been through a lot on this problem.

No error codes? :huh:

It acts like a retarded timing issue to me. Check again maybe?

Have you rebooted the ECU (disconnect the battery for a few minutes)? :)
 

·
Super Moderator
Joined
·
15,741 Posts
The original poster reports the symptoms of his turbo diesel and the "most recent requestor" says he has the "same problem" with his gasolene engined GV.

Cmon guy - this is when you start a new thread - did the dealer really tell you the problem was 'low fuel'?

Do yourself and us a favour.
 
1 - 7 of 7 Posts
Top