Suzuki Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Alright, so I've been wanting to buy a samurai for quite some time now, and after 4 failed attempts at buying one (I'd had 4 different samurai bought from under me), I was finally able to get my hands on one. It drove home just fine(it felt a little unstable, but I figured it was from the lift or something), from Temecula to San Diego, about a 90 mile trip. I get home, turn it off, and go upstairs. About an hour passes and i go to turn it on and it doesnt want to turn over. I let another couple hours pass, maybe like 6, I try again, and tp my suprise it turns back on, so I go for a little drive down to walmart to pick up a few items, but again I'm having trouble starting it. I'm able to make it back home, but I haven't tried to turn it on again today (this all happened yesterday). I did notice some white smoke, it appeared to be coming out of the exhaust pipe, the one that goes down into the cat, I noticed that it was leaking some oil, but I'm not too familiar with Samurai, or cars in general. The guy I bought it from said it may need a little more carb cleaner, if thats the case, could I have some recommendations?
Again, I'm new to Samurai, and cars in general.
Any help or insight is much appreciated, thanks in advance, crispy.


TLDR: bought a samurai, drove it home, 90 miles, having problems starting it.
 

·
Registered
Joined
·
32 Posts
It could be anything from a plugged Cat. to needing an overhaul. I would have it inspected. A compression test will tell a lot. A friend of mine bought one that run poorly. It had a plugged Cat and 0 compression in 2 of the cyls.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
Well since then I've started it up just fine, let it warm up and everything, it seems to spit out some water with some black stuff (from the tailpipe), if you rub it between your finger it kin of just makes a mess and smells somewhat metallic, maybe carbon buildup or burning too rich? I assume cleaning the fuel system would be a good idea?
And when I'm driving at a low speed, lets say driving in my aprtments, if I put it in neutral it'll just like turn off, the battery and seat belt lights on the gauge cluster will turn on, and if I'm still moving and put it into gear, it'll start up, like a push start...
I assumed it was my lack of skill when it came to driving stick (I've only done it a couple of times, but enough to get a decent feel for it), but I noticed that it happened several times. Usually in neutral with the clutch pushed in, getting ready to gear down usually.
I read somewhere about adjusting the choke valve to set the idle a little higher when driving, does this sound like that'd be the case...?
any insight is much appreciated, thanks.
 
1 - 3 of 3 Posts
Top