Suzuki Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
23 Posts
Discussion Starter #1
I live in the UK and am new to Altos - I have a 1999 GL 993cc four cylinder version.
1. Where is the fuse box pls?
2. The rear washer does not work despite using a foot pump to force air into the pipe from the engine compartment. Despite using substantial pressure it's still blocked. Any ideas - common fault?
3. I don't seem to be able to get any technical info or a wiring diagram online - are there any please.
...Thanks in advance.
 

·
Registered
Joined
·
4,481 Posts
I
2. The rear washer does not work despite using a foot pump to force air into the pipe from the engine compartment. Despite using substantial pressure it's still blocked. Any ideas - common fault?
yep very common fault, pull the nozzle out and check the line is clear. Very common for the nozzle to clog and corrode, a single strand of wire brush wire is the right size as a probe to unblock it thru the nozzle orifice. They build up a lump of stuff inside the assembly, poking it clear will fix it for about 2 seconds, you need to get in to it from the hose side as well and get all the rubbish out.

Soaking it for a few days in white vinegar may help depending on the corrosion
 

·
Registered
Joined
·
23 Posts
Discussion Starter #6
Simple!

welcome to the forum
Thanks.....it's only by looking at the parts catalogue that I have realised just how simple my Alto is - everything appears to be stripped down to the minimum - like one silencer in the exhaust system - less to go wrong!
 
1 - 6 of 6 Posts
Top