Suzuki Forums banner

1 - 10 of 10 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I'm new here and I was wondering if anyone could help me. I have a 2006 forenza, and the problem that I am having is that on some days when i go out in the morning to start my car it wont start. It will start up run for a second then shudder and die. It will do it several times before i get it to start and stay running. Then when I start to drive it and shift into gear the car will start to move then it will jerk one time (prety hard) as I'm moving. Has anyone encountered this or have any idea whats causing these problems?
 

·
Registered
Joined
·
58 Posts
My dad was having the same problem with his company car which was a 06' forenza or maybe verona. Anyways to make things short the trans suck in these thing. Yes u would need to take the car to the dealer and have it fixed. Most likely the ECM like the other guy said. Good luck and let us know if you need anything else.
 

·
Registered
Joined
·
83 Posts
Syith said:
Yes its on the 06' its called cold start, I had the same thing just take it to your dealer and tell them you need the ECM update for the 06'. It took about an hr. they have to remap your ECM after that your all good.
Syith ,

would you happen to know what other issues this update fixes?

I had the ECM update when my car wasn't shifting properly and the check engine came on. Just wondering if the update fixes many issues or am I gonna have to go back to the dealership in the winter.
 

·
Registered
Joined
·
221 Posts
Syith said:
Low RPM start, low idel, check light keep coming on, on cold days the car would not run as good. After thay done the remap it all works fine now.
+1 yep it worked for me
 

·
Registered
Joined
·
83 Posts
awesome thanks for the reply syith.

Has anyone done intake and exhaust mod to an automatic reno/optra5?

I thought i remebered someone mentioning something about shifting problems with some mods and the automatic transmission.
 
1 - 10 of 10 Posts
Top